Jump to content

Recommended Posts

Hi! I love your mod, I noticed it yesterday and it was like miracle, because I'm just finalizing building of my castle on our server and I was telling myself "it would be nice to have some portcullis and drawbridges". And voila, I found your mod! 🙂 
 

I noticed the waterwheels as well, such is a second miracle, because we plan to build a waterwheel mill in our city under the castle. There is already a building parcel for that. Are you reading my mind or what? 🙂

For the waterwheel, I've an idea regarding of the speed and torque: maybe you can examine a water source, for example count compact water mass from which is the river/stream coming from and from that calculate the speed and torque. It will prevent to create a mill indoors and run it just with a bucket of water, such is a littlebit "cheating" of the realism of the Vintage Story. It would force user to find a big lake for example, to have a high speed and torque.

The water source realism could be configurable switched on/off - maybe some players will not want this limitation...

What do you think?
Fipil

Edited by Filip Nowak
typos
Link to post
Share on other sites

hi @Filip Nowak
thanks for your warm words. i am glad that you like it so much.

 

4 minutes ago, Filip Nowak said:

For the waterwheel, I've an idea regarding of the speed and torque: maybe you can examine a water source, for example count compact water mass from which is the river/stream coming from and from that calculate the speed and torque.

the main problem is, that there is no mass / speed of floating water at now. it only has a liquid level and a floating direction, which are influencing the speed of the waterwheels.
so the idea was mine too, but at now not practicable.

But may be later, if the waterbehavior get more properties. :)

Link to post
Share on other sites
6 minutes ago, Rhonen said:

...

the main problem is, that there is no mass / speed of floating water at now. it only has a liquid level and a floating direction, which are influencing the speed of the waterwheels.
so the idea was mine too, but at now not practicable.

Hi @Rhonen I understand your point, but I what I meant is to count sibling waterbloks from the waterwheel, up to some limit. Just start from the waterwheel and search for sibling waterblocks around the current one, then move current to the sibling and search for the next siblings up to some max limit. During counting can be taken into consideration also the elevation of the found water blocks - if the elevation is increasing, the water is probably falling from some water source above the waterwheel.
So what I mean is just calculate the water mass based only on positions and count of the water blocks. The limit + elevation change should be big enough so user should take water from a big lake or high waterfall to achieve a maximal speed+torque.
Of course, the calculation should be optimized, so it'll not kill the server :-). Maybe it can be done in some thread with low priority. Or per steps, calculate n blocks per server tick (one step), then another n blocks etc. up to the max limit, then each step will report result to the waterwheel - the effect could be smoothly increasing speed and torque.
Does that sound reasonable?
 

Anyway, I'm not pushing you, it's just an idea. Keep up your perfect work!

Filip

Link to post
Share on other sites
37 minutes ago, Filip Nowak said:

Just start from the waterwheel and search for sibling waterblocks around the current one, then move current to the sibling and search for the next siblings up to some max limit. During counting can be taken into consideration also the elevation of the found water blocks - if the elevation is increasing, the water is probably falling from some water source above the waterwheel.
So what I mean is just calculate the water mass based only on positions and count of the water blocks. The limit + elevation change should be big enough so user should take water from a big lake or high waterfall to achieve a maximal speed+torque.
Of course, the calculation should be optimized, so it'll not kill the server 🙂

i will try to get this in a plan if it will be possible without kill the server

  • Like 1
Link to post
Share on other sites

We get the following crash on connection to our server which does not occur if your mod gets removed.

Running on 64 bit Windows with 16 GB RAM
Version: v1.14.7 (Stable)24.01.2021 10:26:08: Critical error occurred
System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
   bei Vintagestory.API.Client.GuiHandbookItemStackPage.PageCodeForStack(ItemStack stack)
   bei Vintagestory.GameContent.GuiDialogHandbook.InitStackCacheAndStacks()
   bei Vintagestory.GameContent.GuiDialogHandbook.loadEntries()
   bei Vintagestory.GameContent.ModSystemHandbook.Event_LevelFinalize()
   bei Vintagestory.API.Common.Action.Invoke()
   bei Vintagestory.Client.NoObf.GeneralPacketHandler.HandleLevelFinalize(_SgnnqebBH0BM984ItS5vhDzSB2c packet)
   bei Vintagestory.Client.NoObf.ClientMain.ExecuteMainThreadTasks(Single deltaTime)
   bei _Ji8ZCYdD03AdlbF434eaGgnZqbbA._h7dO1pJXJpGwhthMPDN9E21LMTB(Single )
   bei _QXfAdKxrJ1KaNtwiV64JU2IvnpC._cl7z8c5uEEaIF1fo0XdijiZbRYk(Single )
   bei _QXfAdKxrJ1KaNtwiV64JU2IvnpC._peV5mb21IaSJTAYBddj4gA99BDo(Single )
   bei Vintagestory.Client.NoObf.ClientPlatformWindows.window_RenderFrame(Object sender, FrameEventArgs e)
   bei System.EventHandler`1.Invoke(Object sender, TEventArgs e)
   bei OpenTK.GameWindow.RaiseRenderFrame(Double elapsed, Double& timestamp)
   bei OpenTK.GameWindow.DispatchRenderFrame()
   bei OpenTK.GameWindow.Run(Double updates_per_second, Double frames_per_second)
   bei _03wQBzfCnykaMLiRGgbQzrKOcn3._QN2fpVgRVBDOLs27GIkkdMlxeKf(_a9AJZVMB0wcgfRPD19VvLtZCbaX , String[] )
   bei _NdjU5BXvKkfOW2d88pNMbEAjE1q._QN2fpVgRVBDOLs27GIkkdMlxeKf(ThreadStart )
-------------------------------

Event Log, last 3 entries
==================================
{ TimeGenerated = 24.01.2021 10:26:09, Site = , Source = .NET Runtime, Message = Anwendung: Vintagestory.exe
Frameworkversion: v4.0.30319
Beschreibung: Der Prozess wurde aufgrund einer unbehandelten Ausnahme beendet.
Ausnahmeinformationen: Ausnahmecode c0020001, Ausnahmeadresse 00007FFD9FE5D759
Stapel:
 }
{ TimeGenerated = 14.01.2021 09:03:01, Site = , Source = .NET Runtime, Message = Anwendung: Vintagestory.exe
Frameworkversion: v4.0.30319
Beschreibung: Der Prozess wurde aufgrund einer unbehandelten Ausnahme beendet.
Ausnahmeinformationen: Ausnahmecode c0020001, Ausnahmeadresse 00007FF84A68D759
Stapel:
 }
{ TimeGenerated = 19.12.2020 00:17:25, Site = , Source = .NET Runtime, Message = Anwendung: Vintagestory.exe
Frameworkversion: v4.0.30319
Beschreibung: Der Prozess wurde aufgrund einer unbehandelten Ausnahme beendet.
Ausnahmeinformationen: System.NullReferenceException
   bei Vintagestory.Client.NoObf.ClientWorldMap.MarkChunkDirty(Int32, Int32, Int32, Boolean, Boolean, Vintagestory.API.Common.Action, Boolean)
   bei Vintagestory.Client.NoObf.ClientWorldMap.loadChunkMT(_dZKT5htC7TsF6hecyrNHONKYFvBA, Vintagestory.Client.NoObf.ClientChunk)
   bei Vintagestory.Client.NoObf.ClientWorldMap+<>c__DisplayClass94_0.<LoadChunkFromPacket>b__0()
   bei Vintagestory.Client.NoObf.ClientMain.ExecuteMainThreadTasks(Single)
   bei _dUwwv9Q3M6hPimkiHEIazbxLr9g._X2niSFpb8ndF6zWsCcobp5QBcvO(Single)
   bei _ydpin5JFjepNgd3JOZRb2z5I5Fg._LvRZFcsDWyPwKLB1F2UK7fQ2N6d(Single)
   bei _ydpin5JFjepNgd3JOZRb2z5I5Fg._GO2qaUrk9dl0IceTLiA7P4LcpAB(Single)
   bei Vintagestory.Client.NoObf.ClientPlatformWindows.window_RenderFrame(System.Object, OpenTK.FrameEventArgs)
   bei System.EventHandler`1[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].Invoke(System.Object, System.__Canon)
   bei OpenTK.GameWindow.RaiseRenderFrame(Double, Double ByRef)
   bei OpenTK.GameWindow.DispatchRenderFrame()
   bei OpenTK.GameWindow.Run(Double, Double)
   bei _Ine8FeGTtDXciSIfaZMHMwCLKGBA._8puLW8J44fiq3A5hthQTfB8WNxc(_SbVlAI6dJIZ4JRt0da0lu23DF14, System.String[])
   bei _lErb0L2e9E9htuT2VVnAsXIZqc7A._8puLW8J44fiq3A5hthQTfB8WNxc(System.Threading.ThreadStart)

 }

Edited by Kai Effelsberg
Link to post
Share on other sites

@Kai Effelsbergit's running without any problems on our server.
Only what i can read that any kind of Handbook problem - may be mod conflict? also wondering that your server crashes while handbook is client information as far as i know.
So you are only opening the handbook and then game crashes? When yes, any kind of other mods which is influencing the handbook?

Edited by Rhonen
Link to post
Share on other sites
12 minutes ago, Rhonen said:

@Kai Effelsbergit's running without any problems on our server.
Only what i can read that any kind of Handbook problem - may be mod conflict? also wondering that your server crashes while handbook is client information as far as i know.
So you are only opening the handbook and then game crashes? When yes, any kind of other mods which is influencing the handbook?

I have removed any other mod before and it crashed until i removed yours.It does crash on connection, so i do not even get onto the server to open up anything. The strange thing is that right after i updated our mod pack last night (cet) it worked, but this morning it did not. For me and others.

Link to post
Share on other sites
7 minutes ago, Kai Effelsberg said:

I have removed any other mod before and it crashed until i removed yours.It does crash on connection, so i do not even get onto the server to open up anything. The strange thing is that right after i updated our mod pack last night (cet) it worked, but this morning it did not. For me and others.

ok understand

 

Quote

System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
   bei Vintagestory.API.Client.GuiHandbookItemStackPage.PageCodeForStack(ItemStack stack)
   bei Vintagestory.GameContent.GuiDialogHandbook.InitStackCacheAndStacks()
   bei Vintagestory.GameContent.GuiDialogHandbook.loadEntries()
   bei Vintagestory.GameContent.ModSystemHandbook.Event_LevelFinalize()
   bei Vintagestory.API.Common.Action.Invoke()

but this error does not happen on our server with the current mod. so without chance to reproducing it, i can not realy help at this point.

also if you say it was running with the update and now not longer... the newest version does not make any remapping.
and when you say you updated your own mod pack to get it run again, then i fear their seems to be a conflict between the mods.

Edited by Rhonen
Link to post
Share on other sites
4 minutes ago, Rhonen said:

ok understand

 

but this error does not happen on our server with the current mod. so without chance to reproducing it, i can not realy help at this point.

1155577658_DesktopScreenshot2021_01.24-11_16_30_11.jpg.720ae36d7a032837ef1c275a85e76aa6.jpg

These are the mods we are using. I think i tried removing MeteoricExpansion, ModBooks, XSkills/XLib, VSo-ModPackage before.

Edited by Kai Effelsberg
Link to post
Share on other sites
8 hours ago, Susel_de_Baibak said:

i found some problem firebrazier are not warming you.

UPD: and if you take it back when it fired the sound will stay 

hmmm interesting... i will investigate both points.

Link to post
Share on other sites
2 hours ago, Susel_de_Baibak said:

I cheсked this problem on separate 1.14.7 version with no other mods, bugs still exist.

so found both, will be fixed soon :) thanks for reporting.

Edited by Rhonen
Link to post
Share on other sites
On 1/24/2021 at 11:55 AM, Kai Effelsberg said:

@Rhonen Now we got another problem:

I have disabled Primitive Survival but now we got this1262089162_VintagestoryScreenshot2021_01.24-11_52_11_45.thumb.jpg.a9263c2a508c5ba100a7fb0e0fc819e0.jpg1535648495_VintagestoryScreenshot2021_01.24-11_52_05_26.thumb.jpg.8632ffc45908089b27f6f885d419f2b6.jpg

 

These bugs do only happen with any version higher than 3.3.3. You must have changed something afterwards that may interfere with another mod, maybe Primitive Survival.

Link to post
Share on other sites
10 hours ago, Kai Effelsberg said:

These bugs do only happen with any version higher than 3.3.3. You must have changed something afterwards that may interfere with another mod, maybe Primitive Survival.

nope, i did not change anykind of namespaces or block-naming for the gates - only added a new big sized Gate.
and what i can see => that is not the new one. that is the gate4x5 if i am right, this one is not new. also it's drawing only one-side, but all shapes are dual sided.
i believe you that this happen, but what you think should i do?!

Edited by Rhonen
Link to post
Share on other sites
10 hours ago, Kai Effelsberg said:

These bugs do only happen with any version higher than 3.3.3. You must have changed something afterwards that may interfere with another mod, maybe Primitive Survival.

It looks like a vanilla mapping table bug. I doubt that the mod could somehow break it on purpose, especially considering that Rhonen does not modify it in any way. Most likely, if you create a new world, everything will be fine.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.