Jump to content
Sign in to follow this  
stefan

Problem running on Linux (missing UIAutomationWinforms.dll)

Recommended Posts

hello!

i would like to run this game on Linux:

* OS: KDE Neon (based on Ubuntu)
* Propriatery Nvidia driver is installed
* I installed the packages "mono-complete" and "mono-runtime"

I ran the game successfully on a few different distros over the years and cannot remember having this problem.

When I try to run the game (using "mono ./Vintagestory.exe") I get the following warning:

15:29:21 [Client Warning] Client side assembly resolver did not find the assembly in the binary path, the lib path or the mods path. Tested for the following paths:                                                                                                                                                                
/home/stefan/Downloads/vintagestory/Lib/UIAutomationWinforms.dll                                                                                                  
/home/stefan/Downloads/vintagestory/UIAutomationWinforms.dll                                                                                                      
/home/stefan/.config/VintagestoryData/Mods/UIAutomationWinforms.dll                                                                                               
/home/stefan/Downloads/vintagestory/Mods/UIAutomationWinforms.dll

15:29:21 [Client Debug] Creating game window with window mode Fullscreen
15:29:21 [Client Notification] Graphics Card Vendor: NVIDIA Corporation
15:29:21 [Client Notification] Graphics Card Version: 3.3.0 NVIDIA 440.100
15:29:21 [Client Notification] Graphics Card Renderer: GeForce GTX 750/PCIe/SSE2
15:29:21 [Client Notification] Graphics Card ShadingLanguageVersion: 3.30 NVIDIA via Cg compiler
15:29:21 [Client Notification] Cairo Graphics Version: 1.15.10
15:29:21 [Client Notification] OpenAL Version: 1.1 ALSOFT 1.18.2
15:29:21 [Client Notification] C# Framework: Mono 4.6.2 (Debian 4.6.2.7+dfsg-1ubuntu1)
15:29:21 [Client Notification] OpenTK Version: 3.1.0 (A set of fast, low-level C# bindings for OpenGL, OpenGL ES and OpenAL.)
15:29:21 [Client Notification] Start discovering assets
15:29:21 [Client Notification] Found 8 base assets in category lang
15:29:21 [Client Notification] Found 0 base assets in category journal
15:29:21 [Client Notification] Found 0 base assets in category patches
15:29:21 [Client Notification] Found 16 base assets in category config
15:29:21 [Client Notification] Found 0 base assets in category worldproperties
15:29:21 [Client Notification] Found 31 base assets in category sounds
15:29:21 [Client Notification] Found 2 base assets in category shapes
15:29:21 [Client Notification] Found 72 base assets in category shaders
15:29:21 [Client Notification] Found 13 base assets in category shaderincludes
15:29:21 [Client Notification] Found 58 base assets in category textures
15:29:21 [Client Notification] Found 3 base assets in category music
15:29:21 [Client Notification] Found 0 base assets in category dialog
15:29:21 [Client Notification] Found 203 base assets in total
15:29:21 [Client Notification] Loading sounds
15:29:21 [Client Notification] (Re-)loaded frame buffers
* Assertion at local-propagation.c:330, condition `ins->opcode > MONO_CEE_LAST' not met

Stacktrace:

  at <unknown> <0xffffffff>
  at OpenTK.BindingsBase.MarshalStringArrayToPtr (string[]) <0x0009f>
  at OpenTK.Graphics.OpenGL.GL.ShaderSource (uint,int,string[],int*) <0x00023>
  at OpenTK.Graphics.OpenGL.GL.ShaderSource (int,string) <0x0006f>
  at Vintagestory.Client.NoObf.ClientPlatformWindows.CompileShader (Vintagestory.Client.NoObf.Shader) <0x0017f>
  at Vintagestory.Client.NoObf.Shader.Compile () <0x00024>
  at Vintagestory.Client.NoObf.ShaderProgram.Compile () <0x000d3>
  at Vintagestory.Client.NoObf.ClientPlatformWindows.Start () <0x00a77>
  at _gilSYm6aSzOct8TKUm64HAM8OHp._tyidesQGCE1oKHv8YEo8HwYCSty (_RxGTCHor7fqeGRNMEH5pZVfBHHK,string[]) <0x00ab7>
  at _gilSYm6aSzOct8TKUm64HAM8OHp/_6eMaTe2Mm7x9arQAXqYqer2f92b._9FxIL4yW4T9qebkEnphf1OK8WKC () <0x00027>
  at _xmrDk9pogtvR6xvbzmBc2dtFsbu._tyidesQGCE1oKHv8YEo8HwYCSty (System.Threading.ThreadStart) <0x00036>
  at _gilSYm6aSzOct8TKUm64HAM8OHp..ctor (string[]) <0x005e3>
  at _gilSYm6aSzOct8TKUm64HAM8OHp._ZoExSApIn1CvLIbxB8wFSJpix7A (string[]) <0x002df>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0x000d1>

I was not able to locate this missing .dll file online. The rest of the output is quite long, but I will post it if it helps.

Edited by stefan
added "UIAutomationWinforms.dll" to topic title

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.