Jump to content
Sign in to follow this  
Milo Christiansen

Couple of bugs.

Recommended Posts

Two bugs I have observed:

  1. Sometimes molds still looked filled even after removing the item if they are left to sit for a long time. Picking the mold up leaves the "metal" plane behind on the ground if this happens.
  2. Charcoal pits with multiple layers of wood produce less charcoal than a pit with a single layer (assuming both pits have the same amount of wood).

Also bamboo doesn't seem to have a way to replant it and samplings in general are far too rare unless you break every single leaf block before cutting the tree  down.

Share this post


Link to post
Share on other sites

I think the low sapling count may be intentional, as TFC had no way to get saplings unless you broke the leaves by hand. That being said, TFC also had the scythe which let you destroy multiple leaf blocks quickly to make up for that.

 

Edit1: Yeah, I'm getting the mold visual bug too. I've only seen it when using two molds placed on the same block, though

Edit2: Reloading the world fixed the issue

Edited by Shaun Graham

Share this post


Link to post
Share on other sites

Shears are the VS equivalent of the TFC scythe.  Very handy for removing all the leaf/branch blocks first, and getting the sticks and saplings.  The shears do have a slightly lower chance for drops vs. individually breaking the leaves, but it's far faster.

As for the metal plane bug with molds, it's known for a long time.  But as mentioned it's fixed on reload so it's not a terribly pressing bug I guess.

Share this post


Link to post
Share on other sites

Is there a way to reliably reproduce the metal plane staying behind upon mold removal? I know saraty also once or twice observed sign text not disappearing upon breaking it. That is basically the same bug, as in, the client block entity does get notified of it's removal. 

It does seem to only occur in multiplayer, does it? I currently don't know the cause, but a larger sample of bug reports might help us track it down

Share this post


Link to post
Share on other sites

It seems to happen almost every time if you leave the mold sit for a long time. For example, I have 4 pick molds and I cast them all at once, then I remove the pick heads as I need them (which is fairly often as I am doing a lot of quarrying). Generally from the second mold on they exhibit this issue.

I wouldn't know if this happens in single player or not, I have actually never played single player...

Share this post


Link to post
Share on other sites

Generally I am either down my quarry (~50 blocks deep), or out at the end of the road (hundreds of blocks away) several times between casting and using the last tool. So most of the time the chunk is still inside my view distance, but not in my immediate vicinity (it does go out of view when working on the road, but there have been times where the bug triggered, but I never did anything but work in the quarry).

Anyway, nowadays I pick up all my molds and cast parts after every casting run, since I have too many to just leave them laying around, so I haven't seen the issue for quite some time.

Share this post


Link to post
Share on other sites
On 2/1/2018 at 12:54 AM, Milo Christiansen said:
  1. Charcoal pits with multiple layers of wood produce less charcoal than a pit with a single layer (assuming both pits have the same amount of wood).

Also bamboo doesn't seem to have a way to replant it and samplings in general are far too rare unless you break every single leaf block before cutting the tree  down.


Bamboo has no saplings yet, yes. That's merely a missing feature. (It has a different tree growth algo)

The charcoal pit is reliably reproducable? Any average numbers how much less it produces? I had a look at the code, doesn't look like somethings wrong. It randomly produces 12.5% to 25% of charocal for each column of wood (it sums up the total amount of logs). 

 

Share this post


Link to post
Share on other sites

I'll have to run a few tests next time I make charcoal, shouldn't be long as I need more soon. I think I'll try a bunch of smaller pits and report results for each. See if it holds up under close investigation.

Edited by Milo Christiansen

Share this post


Link to post
Share on other sites

I just checked a charcoal pit that was 3x3x2, and full of logs. Instead of getting 9 "x layers of charcoal" blocks when the burn finished, I had 9 "game:block-charcoalpile-8" blocks. 

I'm grasping at straws here, but I think the issue has to do with the game placing additional blocks on top of the bottom layer of finished charcoal blocks. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.