Jump to content

Horrible LAN experience


Recommended Posts

First and foremost: the lack of clear and concise information on this particular subject is annoying. Nowhere is there an explanation of how to join a LAN server, only how to set one up. I don't see LAN servers in either my servers, or the servers available. I have spent the last hour and a half attempting to figure out where to see a LAN server, how to forward a port (I -think- I've done it through my McAfee), and scrounging through the forms looking for any explanation that doesn't assume that people know what they're doing.

So my question is twofold.
1: How do I join a friend's LAN server (AKA: how do I see a LAN server. We are in the same building connected to the same internet)?
2: Will the multiplayer experience be receiving any further information and/or explanation?

Link to post
Share on other sites

To join a friend's, you will need to make sure the computer/router is not blocking port 42420 and then you need to click "add server" within the Multiplayer menu, and put in that person's local ip4 address. That's all you have to do for LAN. 

For allowing the server to be reachable by those on the internet, you need to click "Open to Internet". If the returned text next to the IP lists is not green, then it didn't work. That will mean you need to somehow get into your router (which could be difficult if you're in a dorm or something) and enabled UPnP and DMZ. Then you need to add the port forwarding options (port 42420 as TCP and public ip4 address which you can obtain here. Leave the external IP one as an "*") and then relaunch/test the game. If the text returns green, you've set it up all correctly.

If for some reason you cannot get port forwarding to work, you can use options like Hamachi or ZeroTier.

Edited by Rhyagelle
Link to post
Share on other sites

Welp. None of that worked. My router settings page does not have a UPnP page, so not sure how to do that. I -think- I'm using Hamachi right. and when we try to connect to either of our games it says that the connection didn't respond (Paraphrasing, too annoyed to get the exact quote right now). I am at a loss. Is there no way to set up easier multiplayer?

Link to post
Share on other sites

The easiest way to set up multiplayer if for some reason you cannot allow the port through and enable UPnP is with Hamachi or similar programs like ZeroTier (there's even a thread here detailing how to use it). 

What router do you have? I could help you figure it out. It could very well be under another setting, or put under a different name (my Arris does that). As for Hamachi, what error did it give? I know you were frustrated, but if you could repeat it and take a screenshot of it, it could help a lot.

Link to post
Share on other sites

First, check that it isn't Windows Firewall. You'll have to allow it in "allow an app through windows firewall", your antivirus, and make an inbound rule both for the program on TCP port 42420 and a generic rule for allowing TCP port 42420 in Windows Defender Firewall with Advanced Security.

I've had trouble with Windows Firewall unless I did all three or even four of those.

And even then, Vintage Story might not even be listening on the right network interface, for either Hamachi or your LAN. IPv6 can cause issues too.

Otherwise, you could use standard portforwarding, but if you have Comcast and you are using the stock cable modem with Comcast you will NOT be able to portforward, regardless of if you add the port or not. The problem is that portforwarding, either intentionally or unintentionally, was broken in the firmware years ago. It says it does it, but it does not. Here's the safest way to do it otherwise:

  1. Put a Linux server on your LAN, and look up the obligatory steps (installing, generating an SSH key, copying it to the server, disabling password authentication, fail2ban, ufw, etc)
  2. Either follow the dedicated server instructions or use rinetd to forward the port from your PC's IP
  3. DMZ the entire server, exposing all ports on the server directly to the internet

I would recommend not putting your Windows PC under DMZ. Windows has a lot of network services that it runs that could lead to your PC being compromised remotely.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.