Jump to content

Recommended Posts

2 hours ago, ZigTheHedge said:

@Julius van Vern, can you please test the server behavior? It should work, but I cannot be sure 100% ^_^

tradeomat_v1.13.4-1.2B.zip 16.93 kB · 0 downloads

P.S: Config file is in ModConfig. Called TradeomatConfig.json

I will try it :)

Edit: Thank you. It works :) 

Edited by Julius van Vern
  • Like 1
Link to post
Share on other sites
  • ZigTheHedge changed the title to Trade-o-mat [v1.3B]
  • ZigTheHedge changed the title to Trade-o-mat [v1.31B]
  • ZigTheHedge changed the title to Trade-o-mat [v1.3.2B]
  • ZigTheHedge changed the title to Trade-o-mat [v1.3.4B]

With 1.3.4-B, when looking toward my tradeomat and shift rclicking, I got this:

Had nothing in hand, but the tradeomat was selling lit torches for extinguished torches.  Will work on a simpler repro, but I was hoping this might help for now.  

Running on 64 bit Windows with 24 GB RAM 
Version: v1.14.2 (Stable)12/11/2020 12:02:38 AM: Critical error occurred
System.NullReferenceException: Object reference not set to an instance of an object.
   at Vintagestory.API.Client.GuiElementDynamicTextHelper.GetDynamicText(GuiComposer composer, String key)
   at tradeomat.src.TradeomatBlock.BETradeBlock.OnReceivedServerPacket(Int32 packetid, Byte[] data)
   at Vintagestory.Client.NoObf.GeneralPacketHandler.HandleBlockEntityMessage(_yYcLwwVgddc6OWOmqOfREe6xnKd packet)
   at Vintagestory.Client.NoObf.ClientMain.ExecuteMainThreadTasks(Single deltaTime)
   at _uWwiuXC8cGTH1JnsWiUY9FUaXOo._0WtXQJqGAidcdKMfPHF0OxDIauE(Single )
   at _ydpin5JFjepNgd3JOZRb2z5I5Fg._LvRZFcsDWyPwKLB1F2UK7fQ2N6d(Single )
   at _ydpin5JFjepNgd3JOZRb2z5I5Fg._GO2qaUrk9dl0IceTLiA7P4LcpAB(Single )
   at Vintagestory.Client.NoObf.ClientPlatformWindows.window_RenderFrame(Object sender, FrameEventArgs e)
   at System.EventHandler`1.Invoke(Object sender, TEventArgs e)
   at OpenTK.GameWindow.RaiseRenderFrame(Double elapsed, Double& timestamp)
   at OpenTK.GameWindow.DispatchRenderFrame()
   at OpenTK.GameWindow.Run(Double updates_per_second, Double frames_per_second)
   at _Ine8FeGTtDXciSIfaZMHMwCLKGBA._8puLW8J44fiq3A5hthQTfB8WNxc(_SbVlAI6dJIZ4JRt0da0lu23DF14 , String[] )
   at _lErb0L2e9E9htuT2VVnAsXIZqc7A._8puLW8J44fiq3A5hthQTfB8WNxc(ThreadStart )
-------------------------------

 

Link to post
Share on other sites

@Chime Hey!

Thanks for the report, but I cannot reproduce the issue.

1. Which tradeomat are you using?

2. What other mods are installed (with versions)

3. Are you using any interface tweaks? (immersive mode, real first-person mode etc.)

4. Are you playing on dedicated server?

Edited by ZigTheHedge
Link to post
Share on other sites
On 12/12/2020 at 7:05 PM, ZigTheHedge said:

@Tech_RabbitHey!

Wow! I hope you’ve got the backup. But that behavior is quite impossible :) Tradeomat isn’t designed to replace any blocks and don’t use block remapping for this to happen. It seems like there are other things to blame.

Still when I installed JUST tradeomat, it asked for a remap and remapped ice to the tradeomat secondary look, frosted cattail turned into kapok fence, and vertical glass slabs turned into pine fence. I had done a remap before installing it (after 1.14.2) so don't think it was any other mods or main game unless it was something weird with main game + tradeomat

Link to post
Share on other sites

I haven't been able to repro it, unfortunately.  This was with the stall-cart style tradeomat, no interface tweaks, and a dedicated server.  A lot of mods, unfortunately.  If I can get a repro I'll bisect but it's been just the once so far.

Spoiler

1199056457_RopeBridgesv1.0.4.zip
351490713_Acornsv0.2.7.zip
AlphaWeaponPack1.0.2.zip
BetterArchery2.0.0.zip
BetterBackpacks1.0.zip
BetterCratesCC_v1.2.2.zip
Better-Drifters1.0.0.zip
BetterPoultice1.0.0.zip
CarryCapacity-1.14-0.5.2.zip
cavepaintings_v1.14-1.1.2-A.zip
compatibilitylib_v1.13.4_1.1.0.zip
Craftables1.0.1.zip
ExtraChestsCC_v1.2.0.zip
fancytools_0.3.zip
FullDrop1.0.1.zip
IronBackpack1.0.0.zip
jackolanterns1.0.6.zip
medievalexpansion-3.1.2.zip
MoreRecipes_v1.14.0-rc.4_v1.4.0.zip
MoreRoads.zip
MoreVariants_v1.14.0-rc.4_v1.2.1.zip
necessaries_v1_14.0-0.7.7-B.zip
NoMolding1.0.0.zip
primitivesurvival2.2.0.zip
QuickerBarrel.zip
Stackables1.0.2.zip
TemporalTinkerer_v2.2.1.zip
tradeomat_v1_14.0-1.3.4-B.zip
UsefulScraps2.0.1.zip
workbench-expansion-1.2.3.zip
zeekea_v1_14.0-1.2.5-B.zip

 

Link to post
Share on other sites
7 hours ago, Tech_Rabbit said:

I had done a remap before installing it (after 1.14.2) so don't think it was any other mods or main game unless it was something weird with main game + tradeomat

I'm still unable to reproduce it :( Let's try it a different way: You had a world in 1.13.4 without tradeomat, then you updated it to 1.14.2 and accepted the remaps, then you added the tradeomat and accepted the remaps again. Correct?

And just in case - take a look at your server-debug.txt log. I can see remaps there every time I load the savegame even without tradeomat-mod active. You can also check your assets/game/config/remaps.json and search there for suspicious remaps.

Edited by ZigTheHedge
Link to post
Share on other sites
  • 2 weeks later...
  • ZigTheHedge changed the title to Trade-o-mat [v1.5.5]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.