Jump to content

Meteoric Expansion v1.0.4


Recommended Posts

I actually have several worlds that I've put anywhere from 40 to 80 hours into and never had a meteorite hit my base area.

It feels like having the setting at 1 chunk minimum actually has it hit at least 1 chunk away.  Only the mod writer could verify that though.

 

*edit*

Hmm, well my new closest one is still over 50 blocks from the base. The pink marker is spawn and I had my mouse over my location at where it hit. I suppose it may depend on how large your building is, it may not be worth the risk?

 

meteorite strike.jpg

Edited by Lisabet
Link to post
Share on other sites
  • 2 weeks later...

I've been using this for near two weeks now in non-destructive to test it and not risk turning on destructive due to my large base and I'm glad I have. I love this mod and it's great visually but I did see a meteor hit my largest castle tower right where my bedroom and some storage is.

This isn't a detractor from the mod, my castle and town is just large.

Link to post
Share on other sites

Simply configure it to the minimum size of your base. The blocks it destroys is usually like not bigger than a 5x5x5 area(or so). I would also turn down the frequency, due to receiving way more uranium in the span of a couple days than I think is healthy. Chasing the meteors and having more ores above ground is very nice.

Link to post
Share on other sites

This mod is amazing. A meteorite exploded over my house and the pieces rained down in the dark, it was amazing. I had no idea what the rumbling roar was. it was awesome. I saw you talking about sounds, some break the sound barrier *hint hint*

Link to post
Share on other sites
On 2/8/2021 at 11:50 AM, Craluminum said:

What to do if after each new game (or load the saved game) the config is always returned to default?

It's possible that the value changed in the config is invalid. A new config is generated in such a case to avoid further problems with the mod. Could you post your config file contents so that I can diagnose?

Link to post
Share on other sites
  • 2 weeks later...

I have noticed that with this mod on my Ubuntu server, that sometimes when I connect to the server I get meteors raining down everywhere, like 1 a second. When I leave then return to the server it is ok them. I have a real long time between meteors set on the server config file. I have the mod installed for both client and server. The client config is default. Can't figure out what is going on, but have had it happen a few times in the last week. This is my server config file:

{
  "Destructive": true,
  "MinimumMinutesBetweenMeteorSpawns": 1440,
  "MaximumMinutesBetweenMeteorSpawns": 525600,
  "MinimumSpawnDistanceInChunks": 1,
  "MaximumSpawnDistanceInChunks": 6,
  "MinimumMeteorLifespanInSeconds": 2,
  "MaximumMeteorLifespanInSeconds": 10
}

Link to post
Share on other sites
9 hours ago, CJHKnight2 said:

I have noticed that with this mod on my Ubuntu server, that sometimes when I connect to the server I get meteors raining down everywhere, like 1 a second. When I leave then return to the server it is ok them. I have a real long time between meteors set on the server config file. I have the mod installed for both client and server. The client config is default. Can't figure out what is going on, but have had it happen a few times in the last week. This is my server config file:

{
  "Destructive": true,
  "MinimumMinutesBetweenMeteorSpawns": 1440,
  "MaximumMinutesBetweenMeteorSpawns": 525600,
  "MinimumSpawnDistanceInChunks": 1,
  "MaximumSpawnDistanceInChunks": 6,
  "MinimumMeteorLifespanInSeconds": 2,
  "MaximumMeteorLifespanInSeconds": 10
}

I think the problem is that the number 525600 is just so excessively large that, when converted to milliseconds, the number is just too large to fit in an integer or double. It turns that number into a negative and thus, the spawner will always spawn meteors indefinitely.

With a little reworking I THINK I can fix it to work. I'll see what I can do-but for now, you could dial back the maximum minutes to avoid the problem.

Link to post
Share on other sites
25 minutes ago, Taska Raine said:

I think the problem is that the number 525600 is just so excessively large that, when converted to milliseconds, the number is just too large to fit in an integer or double. It turns that number into a negative and thus, the spawner will always spawn meteors indefinitely.

With a little reworking I THINK I can fix it to work. I'll see what I can do-but for now, you could dial back the maximum minutes to avoid the problem.

Ok sounds good. I didn't think a large integer would be a problem lol

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.