Jump to content

Expanded Foods 1.5.3.pre


l33tmaan

Recommended Posts

https://mods.vintagestory.at/show/mod/11

This one, specifically.  Placing pumpkins was crashing the game due to it.  We've been very careful and slow to update with each little change they make because various mods break each time lol

That said... it is doing it again and I'm not so sure it's a latency thing as I'm the one hosting and it happens to all three of us. With meats specifically being smashed and cut.

Edited by Christopher Bravard
Link to comment
Share on other sites

Im having this problem on single player! Cant seem to make much in the saucepan other than...salt. Have tried a bone broth and a herbal tea. Its not getting hot with it. Immersive mouse mode is off. 

EDIT: working now. seems to be an intermittent issue. 

Edited by Candles
Link to comment
Share on other sites

So are you planning on keeping bottles being fired in a firepit?  If so there is an issue where you can put a stack of unfired bottles in a firepit and get out a stack of fired bottles.  The first fired bottle blocks the entire process, which means that you have to keep taking out one bottle at a time to keep them going.

Edited by JamesB
  • Mind=blown 1
Link to comment
Share on other sites

Noticed that you can dupe raw meat in inventory, put raw meat in middle crafting grid then (obsidian, maybe other stones works too) stone to make smashed meat, take smashed meat to inventory, click to spot where you took smashed meat and you should have raw meat in your cursor to put back in inventory. 

Tho not 100% sure this is caused directly this mod having ~8 other mods too, should test more later more.

EDIT: Disabled other mods and still works. 

EDIT 2: also tried to reinstall VS fully, works on when this mod is installed, so quite sure it is bug in this mod.

EDIT 3: Single player, not tested in multiplayer

Edited by Bentorium
  • Confused 1
Link to comment
Share on other sites

I've also noticed the duping on smashed meat.  I have also had interesting experiences with making an herbal crust pie.  I can have all ingredients on the hotbar, make the pie and pick it up in the hotbar, but if I move ingredients to inventory they will revert to their original amount and the pies will vanish when putting them in the oven.  If I keep the pies in the hotbar and then add to the oven, they bake up.  The dupe behavior also will go away after a bit of time or taking other actions. 

  • Like 1
Link to comment
Share on other sites

11 minutes ago, Choosingzero said:

For me meat nuggets are totally borked, if i try to make it it copies the original meat but gives me a random amount of nuggets that dissappear if interacted with. however if i back out of my game and come back in the original meat will be back in the vessel/inventory.

On multiplayer and singleplayer if you try to smash meat with stones, it crashes the game entirely.  In multiplayer, it crashed the entire group out. Can only use a wooden mallet....and the durability of the wooden mallets is insanely low. It takes 2 - 3 to do large quantities of meat.

Link to comment
Share on other sites

Something about expanded foods has been crashing my game. I can run my save fine with the mod disabled, but with it enabled I crash immediately upon save load.

Sadly I don't speak crash log.

Spoiler

Running on 64 bit Windows with 16 GB RAM
Version: v1.15.5 (Stable)2021-08-13 14:14:40: Critical error occurred
System.NullReferenceException: Object reference not set to an instance of an object.
   at ExpandedFoods.ItemExpandedRawFood.GenMesh(ICoreClientAPI capi, String[] ings, Vec3f rot, ITesselatorAPI tesselator)
   at ExpandedFoods.ItemExpandedRawFood.OnBeforeRender(ICoreClientAPI capi, ItemStack itemstack, EnumItemRenderTarget target, ItemRenderInfo& renderinfo)
   at Vintagestory.Client.NoObf.InventoryItemRenderer.GetItemStackRenderInfo(ClientMain game, ItemSlot inSlot, EnumItemRenderTarget target)
   at Vintagestory.Client.NoObf.InventoryItemRenderer.RenderItemstackToGui(ItemSlot inSlot, Double posX, Double posY, Double posZ, Single size, Int32 color, Boolean shading, Boolean rotate, Boolean showStackSize)
   at Vintagestory.API.Client.GuiElementItemSlotGridBase.RenderInteractiveElements(Single deltaTime)
   at Vintagestory.API.Client.GuiComposer.Render(Single deltaTime)
   at Vintagestory.API.Client.GuiDialog.OnRenderGUI(Single deltaTime)
   at Vintagestory.API.Client.HudElement.OnRenderGUI(Single deltaTime)
   at Vintagestory.Client.NoObf.HudHotbar.OnRenderGUI(Single deltaTime)
   at Vintagestory.Client.NoObf.GuiManager.OnRenderFrameGUI(Single deltaTime)
   at Vintagestory.Client.NoObf.ClientEventManager.TriggerRenderStage(EnumRenderStage stage, Single dt)
   at Vintagestory.Client.NoObf.ClientMain.TriggerRenderStage(EnumRenderStage stage, Single dt)
   at Vintagestory.Client.NoObf.ClientMain.RenderToDefaultFramebuffer(Single dt)
   at _EMxDKvc7iN7J6hlNFQiKeoxg0Mm._ra0MgpFbqkfgNETNlZ5CppyVnhE(Single )
   at _Wwq7msw90Af4XU7mxkxAUKyrS5B._iIGaTXNE8VYTpgEu9zjpAQyJSxd(Single )
   at _Wwq7msw90Af4XU7mxkxAUKyrS5B._vCB99EztL7cSfmplK8tyTwrQQxC(Single )
   at Vintagestory.Client.NoObf.ClientPlatformWindows.window_RenderFrame(Object sender, FrameEventArgs e)
   at System.EventHandler`1.Invoke(Object sender, TEventArgs e)
   at OpenTK.GameWindow.RaiseRenderFrame(Double elapsed, Double& timestamp)
   at OpenTK.GameWindow.DispatchRenderFrame()
   at OpenTK.GameWindow.Run(Double updates_per_second, Double frames_per_second)
   at _q065sSmA3CNgGuKTGnlAjR4ljPw._WkSl7yfiyr5DwPiSMvTudNAhp6(_t3ILnyYBq5OoYhhBY3JeTWgFmJDA , String[] )
   at _DBu5wiQWRAHGS5G2jiCKymvQ9yE._WkSl7yfiyr5DwPiSMvTudNAhp6(ThreadStart )
-------------------------------

Event Log entries containing Vintagestory.exe, the latest 3
==================================
{ TimeGenerated = 2021-08-13 12:38:00, Site = , Source = Windows Error Reporting, Message = Fault bucket 1308234530184273593, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: Vintagestory.exe
P2: 1.15.5.0
P3: 61123ac1
P4: KERNELBASE.dll
P5: 10.0.19041.1151
P6: 891df6d3
P7: c0020001
P8: 0000000000034ed9
P9:
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER6CF4.tmp.mdmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER711B.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER712C.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER713A.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER715A.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_Vintagestory.exe_7b25d616dcc58f727aef5bd7f69ccb3052cda0a5_23fa4891_ead2017b-b43f-445d-bba3-e1f229ee0435

Analysis symbol:
Rechecking for solution: 0
Report Id: 0f383ab8-aad2-4426-9335-23bdc3e1135b
Report Status: 268566528
Hashed bucket: a9517b37b4ed682e3227c85fb6889eb9
Cab Guid: 0 }
--------------
{ TimeGenerated = 2021-08-13 12:37:57, Site = , Source = Application Error, Message = Faulting application name: Vintagestory.exe, version: 1.15.5.0, time stamp: 0x61123ac1
Faulting module name: KERNELBASE.dll, version: 10.0.19041.1151, time stamp: 0x891df6d3
Exception code: 0xc0020001
Fault offset: 0x0000000000034ed9
Faulting process id: 0x2a74
Faulting application start time: 0x01d79061536cfc7f
Faulting application path: D:\DATA\Vintagestory\Vintagestory.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: 0f383ab8-aad2-4426-9335-23bdc3e1135b
Faulting package full name:
Faulting package-relative application ID:  }
--------------
{ TimeGenerated = 2021-08-13 12:37:56, Site = , Source = .NET Runtime, Message = Application: Vintagestory.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0020001, exception address 00007FFFA7284ED9
Stack:
 }

Would going through and disposing of all expanded foods related items and then re-enabling the mod clear this or is something more serious borked?

Link to comment
Share on other sites

6 hours ago, l33tmaan said:

It sounds like there's something that transitioned inside a firepit or oven that's not working properly. What have you cooked in that area recently?

I haven't played since before the first stable release of 1.15, so I can't quite remember what I was up to. I poked around with the mod disabled and the only thing I found in firepits/ovens was a couple of saucepans that may have had things in them and a (now empty) pot in an oven. I assume that I was trying to make a stew with maybe meat nuggets.

Link to comment
Share on other sites

13 minutes ago, l33tmaan said:

Try going into creative? You can respawn them afterwards that way. It's /gamemode 2.

It lives! Smashed the saucepans, kicked out the firepits, sent the pot into the void, and even broke the cast iron oven to be extra sure. Save loads with the mod enabled now, thanks!

  • Like 1
Link to comment
Share on other sites

I've been testing it out, the duplicating glitch thing. It seems to only work on the raw redmeat and bushmeat with both the smashed meat and meat nuggets. Fish fillets from Primitive Survival work fine, as do making the chopped version of fish nuggets and veggies. Also, on multiplayer, trying to make the smashed redmeat/bushmeat disconnects me from my friends server. Haven't tried making the meat nuggets, but I'm assuming it'll do the same thing. Hope this helps a little bit.

Other than that, love, love, -love- your mod, l33tmaan. It's one of the few mods that its a hard requirement for me in my playthroughs. Thank you so very, very much for all your hard work that you put into this mod. 💮💖.

Edited by Tanisha Buchholz
Link to comment
Share on other sites

Using the stone recipe for smashed meat throws an exception on the server then my game disconnects. Surprisingly, I still get the finished smashed meat in my inventory after reconnecting. Using the mallet from Acorns mod or normal hammers works fine.

The server throws warnings about game-{stone} or something. So I looked at the json recipe. Seems like there's an error in the returnedStack field so I tried removing it. It works. No more warnings and disconnects. The stone gets consumed though.

Link to comment
Share on other sites

  • l33tmaan changed the title to Expanded Foods 1.5.3.pre

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.