Jump to content

Recommended Posts

The Helve hammer can now forge more than just plates and chains 🙃

Mod support:
To make the hammer support (or not support) custom items, it is enough to add attributes/helvehammerworkable: true or false to the output item. By default, the absence of such an attribute is considered true (changing in config)

Config:

  • AllWorkable - will this work for any items (default - false)
  • DefaultWorkable - default attribute (default - true)
  • AnvilTier - minimum anvil tier (default - 3, iron)

Vanilla items are patched, by default you can do everything except the anvil.

Download: ModDB or GitHub

Edited by DArkHekRoMaNT
  • Like 3
  • Amazing! 1
Link to post
Share on other sites

how to add more recipes ?

like the iron anvil base and top part ?

[
  {
    "file": "game:itemtypes/part/helvehammerhead.json",
    "op": "add",
    "path": "/attributes",
    "value": {}
  },
  {
    "file": "game:itemtypes/part/poundercap.json",
    "op": "add",
    "path": "/attributes",
    "value": {}
  },
  {
    "file": "game:itemtypes/part/helvehammerhead.json",
    "op": "add",
    "path": "/attributes/helvehammerworkable",
    "value": true
  }, 

-------------------------------------------------------------------- DONT WORK

   {
    "file": "game:itemtypes/part/anviltop.json",
    "op": "add",
    "path": "/attributes/helvehammerworkable",
    "value": true
  },
   {
    "file": "game:itemtypes/part/anvilbase.json",
    "op": "add",
    "path": "/attributes/helvehammerworkable",
    "value": true
  },  

----------------------------------------------------------------

  {
    "file": "game:itemtypes/part/poundercap.json",
    "op": "add",
    "path": "/attributes/helvehammerworkable",
    "value": true
  }
]

 

part.json

Link to post
Share on other sites

Is it possible to make this mod work on a server?

I tested it in single player and it works flawlessly (this feature really should be in the vanilla game IMO).  On my family server however the helve hammer creates the shape, you see voxels move and get removed but the completed item never pops off the anvil.

Tried the pickaxe & shears.

I would love it if it could be made to be server side it would be a great addition.

Thanks for your hard work :)

Link to post
Share on other sites
33 minutes ago, MrFlibble said:

Is it possible to make this mod work on a server?

I tested it in single player and it works flawlessly (this feature really should be in the vanilla game IMO).  On my family server however the helve hammer creates the shape, you see voxels move and get removed but the completed item never pops off the anvil.

Tried the pickaxe & shears.

I would love it if it could be made to be server side it would be a great addition.

Thanks for your hard work :)

It's strange, the mod runs on the server. What anvil are you using?

Link to post
Share on other sites
1 minute ago, MrFlibble said:

No changed both client and server config.

You changed AnvilTier. Did you change this in the mod config on the server, or only on the client?
It looks like you only changed this on the client. Therefore, you have a visual part but the item is not actually created.

Link to post
Share on other sites

I did change the server and client configs.

Just double checked the server config and the changes haven't been saved.  I think I've made a schoolboy error and changed to config while the server was running :(

Uploaded the client config to the "STOPPED" server and I've just made a copper sawblade on the bronze anvil as a test.

Thanks for you help debugging my stupidity and thanks for the awesome mod.

Link to post
Share on other sites
1 hour ago, LocoMiner said:

did making the iron anvil work? I tried making one and put three iron on my anvil before I realized the hammer wasn't changing anything 

You should have loose pieces. Considering that the maximum is 3 ingots in height, anvil crafting will be strange

Link to post
Share on other sites
  • 2 weeks later...
  • 4 weeks later...

Does it require both sides edits on that file, seems that server side edit works ok. Changed it server side to use brass anvil, but didnt touch client side configs and it seems to work.

Tho it wont show progress, made iron long blade, took while and ingot changed to blade. Or should there be some progress graphics?

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.