Jump to content

Search the Community

Showing results for tags 'problem'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Vintagestory Discussion
    • News
    • Discussion
    • Suggestions
    • Questions
    • Multiplayer
    • Bugs
  • Creative endeavors
    • Builds
    • Videos, Art or Screenshots
    • Story
  • Vintage Story Modding
    • Mod Releases
    • Modpack Releases
    • Mods & Mod Development
  • Off Topic
    • Other Games
    • General Offtopic

Categories

  • News
  • Community Spotlight
  • Stories

Product Groups

  • Game Account & Game Servers
  • Game Server

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me

Found 1 result

  1. Hello! I'm fairly new to the Vintage Story scene, and its modding in general, but have had some good successes. After getting used to everything and starting to add stuff that I actually wanted modded in, I started work on another part which has to do with modifying the scythe code. This would be the first coding work I'd done in it, so I figured I'd start out by making my own version of the scythe and then replace the vanilla one when I was done. I went about this by essentially just copying the ItemScythe code from the survival github to a new CS file called ItemScytheModded. This is where I intended to play with the tool. After adding the file and adding the code from the ItemScythe file, trying to run the game through Visual studio leads to it not loading my mod. It had been working before adding the code, and seems to load the mod when I remove most of the ItemScythe code. Note that I've tried both having the item registered and not, and both ways the mod still won't load. I've gone about trying to remove all json that included the file (as at first I figured I'd try just patching the scythe to use my class rather than the vanilla), as well as making an entirely different item in my assets folder, but regardless the game won't even load the mod to see those json files. Am I misunderstanding something here or is this weird? Here's the ItemScytheModded code, so you can see it's the same as in the original file: The odd thing about this to me is that even with the file not being used in any json and not being called anywhere, it just stops the game from loading the mod, but does load the mod if I remove parts of the code, specifically all of the overrides.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.