Jump to content

Too stupid to activate gamemode


Keena
 Share

Recommended Posts

Hey there :)
we are having a multiplayer server on an Ubuntu (if this matters) and I seem not able to activate the ability to change one's gamemode.

No matter if I type "/gamemode 2" in ingame chat or in server console with "./server.sh command "player Keena gamemode 2" - it says "Das Ändern des Spielmodus ist in dieser Welt nicht zulässig." (Trans: Changing the game mode is not allowed in this world.)

Anything I am missing or doing wrong, please? 

Thanks  in advance and have a nice day!
 

/home/keena/VintageStory/data/serverconfig.json

Spoiler

"WorldConfig": {
    "Seed": "XXX",
    "SaveFileLocation": "/home/keena/VintageStory/world/world_file.vcdbs",
    "WorldName": "Sample World Name",
    "AllowCreativeMode": true,
    "PlayStyle": "surviveandbuild",
    "PlayStyleLangCode": "surviveandbuild",
    "WorldType": "standard",
    "WorldConfiguration": {
      "worldClimate": "realistic",
      "gameMode": "survival",
      "temporalStability": true,
      "temporalStorms": "sometimes",
      "graceTimer": "0"
    },
    "MapSizeY": null,
    "CreatedByPlayerName": "Keena",
    "DisabledMods": [],
    "RepairMode": false
  },

 

/home/keena/VintageStory/data/Playerdata/playerdata.json

Spoiler

[
  {
    "PlayerUID": "XXX",
    "RoleCode": "admin",
    "PermaPrivileges": [],
    "DeniedPrivileges": [],
    "PlayerGroupMemberShips": {
      "10": {
        "Level": 3,
        "GroupName": "blub",
        "GroupUid": 10
      }
    },
    "AllowInvite": true,
    "LastKnownPlayername": "Keena",
    "CustomPlayerData": {},
    "ExtraLandClaimAllowance": 0,
    "ExtraLandClaimAreas": 0
  },
]

 

Edited by Keena
Link to comment
Share on other sites

Did you restart the server, in case you changed the allowance of creative mode after creating a world?  Maybe you even have to create a new world. I had the same problem once and either i restarted the server or created a new world with that permission set to true, can't remember exactly.

Link to comment
Share on other sites

Mh yes, the server was restarted several times already.
I am not 100% sure anymore, but I thought I created the world already with 

"AllowCreativeMode": true,


Hoewever, isn't there any chance/workaround/fix to activate it, even after creating the world?

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.