Jump to content

Hostility settings not working properly


Pit mod
 Share

Recommended Posts

I got an issue with the hostility of the creatures in my world. It's created as an exploration world, later on i changed the settings for hostility to [off] from the default of [passive], but to no avail. Whatever i change the settings to it takes no effect, any hostile creature is still attacking me on sight, rams are still attacking if provoked. What am i missing here? I am playing latest stable version and the world is freshly created. Any suggestions on how to resolve this?

Link to comment
Share on other sites

Did you restart the world after you put in the new changes via the Worldconfig commands? It should promp you to restart the world in the messages.

As for rams.. Anyone please, correct me if my thought is wrong, but i believe they will retaliate regardless of settings.

If wolves and drifters and locusts still attack you on sight, after you have restarted the world.. Then I agree that's weird.
If you've not restarted it, try that first and go to a different area with new creatures. See if the issue still persists because maybe since they've locked onto you, their AI won't update till they've forgotten about you.

Link to comment
Share on other sites

Yes, of course I restarted the world. ^^

I also tried the console command a couple of times, after each try I restarted not only the world but the complete game just to be sure. Still no change at all. 

What's irritating me is that this error occurs only in this new created world in the latest stable version. My older worlds are not affected  by this and if I switch this parameter just for testing in one them it works just fine and as intended.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.