Jump to content

Eloraam

Vintarian
  • Content Count

    6
  • Joined

  • Last visited

  • Days Won

    1

Eloraam last won the day on June 10

Eloraam had the most liked content!

Community Reputation

2 Neutral

About Eloraam

  • Rank
    Wolf Bait

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Eloraam

    Linux: Critical Error: Requested GraphicsMode Not Available

    Okay, I managed to get mono 5.12.0 installed. I'm still getting corruption on the home screen sometimes?
  2. Eloraam

    Linux: Critical Error: Requested GraphicsMode Not Available

    Gentoo doesn't really have versions, per se. It's a continuously updated distribution with a system called 'portage' that builds packages on the user's system. If they're just using DllImport, then yes, that does sound like a Mono issue. I wonder why I've never seen that before with other C#/OpenGL things? Several Zachtronics games use that combination and work fine. Mono 5.4.1.6 is the most recent ebuild, though. Upgrading to a more recent version would be... a bit more difficult. I'll check for an overlay.
  3. Eloraam

    Linux: Critical Error: Requested GraphicsMode Not Available

    No, this is definitely an OpenTK issue. ld.so.conf is correctly configured to search the NV driver directories first. OpenTK is doing its own thing and pulling up the Mesa library instead. The certificate issue, well, that's 100% Gentoo's fault. But at least there's a workaround.
  4. Eloraam

    Linux: Critical Error: Requested GraphicsMode Not Available

    I've solved that one too! It turns out that Mono in Gentoo ships without any root certificates. All you have to do, if you're also a Gentoo user, is run this command as root: cert-sync /etc/ssl/certs/ca-certificates.crt You should probably update the ca-certificates package before you do that.
  5. Eloraam

    Linux: Critical Error: Requested GraphicsMode Not Available

    A little strace magic and I was able to determine the problem: a simple library path issue. Vintagestory is unconditionally trying to use /usr/lib/libGL.so.1, but it checks for Lib/libGL.so.1 first. Gentoo installs the NVIDIA drivers in /usr/lib64/opengl/nvidia/lib, so all I had to do was create a symlink in Vintagestory's Lib directory. Now I'm getting "Unable to connect to auth server :(".
  6. Eloraam

    Linux: Critical Error: Requested GraphicsMode Not Available

    I believe I'm having the same problem. 14:59:22 [Client Notification] Client logger started. 14:59:22 [Client Notification] Game Version: libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swrast libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swrast X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 153 (GLX) Minor opcode of failed request: 34 () Serial number of failed request: 87 Current serial number in output stream: 85 NVIDIA proprietary drivers on Gentoo. I do a lot of OpenGL development on this machine, so I'm 100% sure that the drivers are otherwise working. I'm happy to help with any debugging you may want.
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.