Jump to content

Mods Corrupted my Only Save File


username
 Share

Recommended Posts

Just picked up the game the other day and have been having a lot of fun. The death mechanics have been a real pain however, so I decided to install some mods to sort it out.

I just tried to run the game, and it failed to load with the mods installed. I tried turning some off to see if I could narrow down which was the problem, but re-loading the game failed. I tried to run it in recovery mode, but that doesn't work (it just starts and stops loading immediately). 

I read the wiki page about recovering saves, and tried to use the SQlite tools suggested there, but that doesn't seem to do anything. I ran the suggested command and it doesn't say anything or output anything (running the tool from the same folder as the save file). 

Is that it for my world? I don't plan to keep playing if I can't save this world. It's been fun, but this is completely killing the experience for me.

Link to comment
Share on other sites

What do you mean by "the game failed"? The error logs are most useful, but even the text messages that float by on load would help. Do you get to at least "It begins"?

BTW, my go to for any time I get a fail to load is to exit the game, make a backup copy of the save, restart the game and disable all mods except Essentials, Survival and Creative, exit the program, delete the Cache directory, then restart. Yes, there may be a lot of undefined blocks, but if it starts, I'm off to the races. Enable a few mods at a time, exit the game, replace your save with a copy of your backup save, delete Cache, restart. Repeat until you figure out which is the problem. I don't recall any time I have not been able to recover a game.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.