Jump to content

Mac OS Catalina broken mouse another one :(


Veritaris
 Share

Recommended Posts

Hiiiiii
Today I've bought VS to play on MacBook Pro 2017 15` on macOS Catalina 10.15.3. 
I've tried to create the world and it was ok. But when I tried to play I could only go forward/back/left/right, but mouse didn't work. I tried to click buttons and wheel, so, wheel worked nice, it scrolled hotbar. Right button did nothing, but when I pressed left button, it looked like I clicked somewhere outside the game 'cause it "paused" until I realise button. Furthermore, when I started to move my mouse (or touchpad) it appeared in the right bottom corner, so problem looks like the game loses mouse focus. I went to forum and, as I understood, it is a common problem on Macs, yeah? Don't you know, will it be fixed in future? 
Anyway, game looks like amazing, so I'll be waiting 'till it be fixed :D

If you need some more info about macOS problems/testing, fell free to contact.

Link to comment
Share on other sites

Weeeell, trying out to fix it I've found a temporary (haha, a joke) solution. I've opened vintagestory.app package as folder via Terminal and started the game with "mono Vintagestory.exe". This helped me and I was able to play with mouse and even touchpad pretty good without bugs for half an hour. 
If I find any more bugs, I'll write it here 

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.