Jump to content

Dedicated Server [SOLVED]


Rhyagelle
 Share

Recommended Posts

Hello,

So my friends do not want to use Hamachi because it is suspect, so I've been trying to set it up to run off my PC instead. It seems to be successful "in some measure" because it says when I hover of the IP it displays:

Quote

 

Port forwarding was successful, but the router returned a private ip address. This means you have an exotic network or internet provider is doing weird multi-routing shenanigans, which makes it unlikely that other players can connect.

Registration at the master server was not successful, external connections probably blocked by firewall.

 

Not being sure what that meant, I had my friends try anyhow. They constantly disconnect/timeout.

I've checked my Windows firewall, it is allowing every single Vintage Story exe and even the folder. Now I checked, and my routers/modem seemingly has Upnp enabled, and there are options on both for port forwarding. But nothing works. I think I might just be screwing something up, because my brother got Minecraft port forwarding to work on the same moderns a few months back (he can't remember how). Anyone know how to do this? If so, would you mind helping me out?

Router/Modem: Arris TG1672G and Sagemcom F@AST 5260 (< this is the one I'm plugged into, it grants us more ethernet ports)

Picture of the Sagemcom port forwarding tab:

Spoiler

 

image.thumb.png.41ac782bfbc968ae9c9b050b986ef586.png

 

 

Thank you for reading,

Rhyagelle~

Edited by Rhyagelle
Link to comment
Share on other sites

Well....I figured it out! LOL

See the problem was that I wasn't directly hooked up to the main device. My ethernet cable is plugged into the Sagemcom device, which pulls access from the main Arris. While I had everything set correctly on the Sagemcom (Upnp enabled, DMZ enabled  & pointing to MY specific computer + port forwarding set up), the Arris was not. It didn't have DMZ enabled, but it had everything else seemingly set up correctly. I did NOT have to set up an additional port on the Arris, only on the device I was actually connected to. 

Once I enabled it on the main device, everything worked. The error message above was green and highlighting it revealed everything was successful. The only thing is...the game advised me to give my friends the wrong IP. I had to give them my PUBLIC IP address, which did not appear correctly in ipconfig /all. I had to find that via a website:

https://www.whatismyip.com

Once that was done, they connected! :)

 

Sorry for the useless thread, but hopefully this helps someone, especially if they have the same devices as me. If not, just make sure DMZ is enabled and POINTING to your actual computer. :)

Link to comment
Share on other sites

  • 2 months later...

You should NEVER set a computer to be in the DMZ. that leaves it completely accessible to the world of hackers.

Only ever forward single ports or small ranges of ports as necessary.

Friends outside your house always need your "public" ip address nothing more. (https://ip4.me or https://ip6.me)

Your "ipconfig" (windows) "ip addr" (linux) ip address is only needed if your are inside the same house on the same network.
And it's also only used to setup the port forwarding correctly

 

P.S. UPNP should also be turned off, or other random programs could easily open ports on your router without your knowledge.

 

Sidenote: according to the image you provided, you would set the following...

Add Rules Manually

Custom service name: Vintage Story

Service: Other

protocol: TCP

External host: BLANK

Internal host: ip address for the machine hosting the server

External Port: 42420

Internal Port: 42420

 

 

 

Be Safe,

I_Died_Tryin

Edited by I_Died_Tryin
added correct links.
Link to comment
Share on other sites

  • 4 months later...

This is really late, but a few days after this post, we replaced our router+modem with a single device. I was sick of going in and out and disabling the settings for security reasons (yes, I know DMZ is a security problem but I was desperate lol). Once we got our new device, I explained to the IT what the problem was with the last two and what I was forced to do to allow port forwarding. He then switched it again and gave me one that did it off the bat automatically.

No more fiddling with settings, DMZ or otherwise, as unfortunately nothing seemed to work. So it was a problem with our router+modem combo. 

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.