Jump to content

modPaths does not follow moving %AppData%\\Roaming to another drive


Hexalan
 Share

Recommended Posts

Environment: VS 1.14.5 on Windows 10

Problem:

Due to disk space issues I moved my AppData/Roaming directory to another drive using Win10's folder location setting and let Windows move all the data.  While all of my save data and other settings are fine the mod path setting is not updated to the new location (see ModManger-pre-edit.png).  Clicking on the "Open Mods Folder" in Mod Manager does open the correct folder and the mods are present (modsfolder.png).  I looked at clientsettings.json and found that the modPath is not updated and still points to the old directory:

"modPaths": [
      "Mods",
      "C:\\Users\\XXXXX\\AppData\\Roaming\\VintagestoryData\\Mods"
    ],

Work around performed:

Shut down VS.
Edited the clientsettings.json file and changed the value of modPaths to the correct location under the moved AppData/Roaming location:

    "modPaths": [
      "Mods",
      "D:\\XXXXX\\AppData\\Roaming\\VintagestoryData\\Mods"
    ],

Restarted VS.

The game client then picked up the mods correctly and seems to be working fine.

Desired behavior:

Provide the user with an editable save data location and make modPaths follow that setting.  This would be my preference but that may break Windows' conformance crap.

or

Change the way modPaths is set to use the system location for %AppData%\\Roaming so that a move of the folder are followed correctly.

*I'm not a coder and these are just my thoughts, there are probably better ways to fix it!*

 

Thanks for creating such a great game!

ModManager-post-edit.PNG

ModManager-pre-edit.PNG

modsfolder.PNG

Link to comment
Share on other sites

Just need to add that I had to make the same change to serversettings.json as well.  The client side only mods were loading the others were marked as disabled per the log file even though they indicated being enabled in the GUI.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.