Jump to content

Macros, their creation and storage


Recommended Posts

In versions 1.16, 1.17 of Vintage Story I was able to create a couple macros through the text console somehow, something like

/macro setcmd ggm gamemode {param1}

and would be able to subsequently be able to toggle my gamemode by 

/ggm s
/ggm c

for survival or creative mode respectively. I noticed that a file "servermacros.json" was created in the root of the data directory.

Since updating to 1.18, I when I type "/ggm <mode>", I get "Command /ggm, too many arguments" in response. I backed up and deleted the "servermacros.json" file to start over. Now I just cannot figure out for the life of me how to create these again! I looked at the wiki for the Server Commands and Macros. I tried "/macro addcmd /gamemode {param1}", then "macro priv build", then "macro save ggm", but then get the error "No such command exists."

The relevent contents of the file "servermacros.json" is

    "Privilege": "build",
    "Name": "",
    "Commands": "/gamemode {param1}\n",
    "CreatedByPlayerUid": "***",
    "Syntax": null,
    "Description": null

If I change the "Name" from "" to "ggm" and try my macro command "/ggm c" or "/ggm s" again, I get the error "Command /ggm, too many arguments" again. I'm not sure what else to try at this point. My intention was to expand "/ggm <mode>" to "/gamemode <mode>". 

If anyone can point out anything I am doing wrong and offer suggestions or correction, I would really appreciate it!

Link to comment
Share on other sites

Thanks! I did not realize that, I'll be using it now! The other macro I've used a lot basically shortens "/worldConfig propickNodeSearchRadius {param1}" into "/pp <radius>", turning prospecting a specific ore into a much-quicker-satisfaction game of Marco-Polo. It, too, has undergone the same fate as my (now redundant) ggm macro 😞

  • Like 1
Link to comment
Share on other sites

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.