Jump to content

Drifters still spawning even with rifts off

Go to solution Solved by Streetwind,

Recommended Posts

I wanted to create a "safe" world to mess around in and so turned off temporal storms, temporal rifts, and creature hostility. But I've still seen drifters even though the rifts are turned off?

This is a snippet of the code I have in the serverconfig.json file on gportal:

"WorldConfiguration": {
            "worldClimate": "realistic",
            "temporalStability": false,
            "temporalStorms": "off",
            "temporalRifts": "off",
            "gameMode": "survival",
            "deathPunishment": "keep",
            "blockGravity": "sandgravel",
            "creatureHostility": "off",
            "creatureStrength": 1,

Do they still spawn even with rifts off, but they just won't attack? Thanks!

Link to comment
Share on other sites

  • Solution
Posted (edited)

Hostile creature spawning in VS works a lot like in Minecraft: wherever the light level is low enough, drifters can spawn.

When rifts were introduced, VS added an additional rule on top: drifter spawning is forbidden under the open sky. Only places that have a solid block above them qualify for spawning (given appropriately low light level). Rifts break this rule, allowing drifters to spawn under the open sky in a small radius around them.

When you turn off rifts, you simply turn off this extra rule and revert the game to Minecraft behavior: drifters can spawn anywhere the light level is low enough, even under the open sky. There is no setting that turns off hostile creature spawning.

However, with creatureHostility=off, these creatures should not attack you.

Additionally, there may be mods available that remove hostile creatures entirely. Click the "Mods" button in the navigation bar at the top of the forums to go to the official mod database.


Edited by Streetwind
  • Like 1
Link to comment
Share on other sites

Ahhhh okay yes that makes sense! So basically if I line my house area with light, I'd see less of them and they won't attack anyway with creature aggression off. 

I did see a mod to completely remove them, so I'll try that out. Thanks, Streetwind.

Link to comment
Share on other sites

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.