Jump to content

Recommended Posts


Greetings...

I posted a week ago or so making a modding suggestion for a new emotion state that could be set to make sheep and other entities flee but be quickly bred out of them, but with the recent 1.15 pre-3 release, we have the option to configure by generation how quickly fleeentity, idle, and melee ai task responses are bred out of an entity. I can acquire the behavior I am looking for now in the ethology mod I've been working on! 🎉

...but I'm not sure how to get it to work.

Asking in discord modding help has not found a solution yet, so I'm posting here to try my luck as I work to understand how to implant this into an entity's .json file.

Using sheep as an example, I added a new fleeentity ai task with no "ondamage" requirement, but added the "maxtamingGenerations: 1" line to the code. It is not working. Neither did "maxtamingGeneration", "maxGenerations", "maxGeneration". 

Here is a copy of the "fleeentity" ai task as inserted into the .json file:

{
  code: "fleeentity",
  entityCodes: ["player"],
  priority: 1.5,
  movespeed: 0.052,
  seekingRange: 12,
  animation: "Run",
  animationSpeed: 3.5,
  sound: "creature/sheep/hurt2",
  maxGeneration: 1
},

If I understand it right, this should result in all gen 2 and higher sheep ignoring this ai task.  It is not working though. All my sheep still run like mad when I am within seeking range.

I also tried adding the "maxGeneration" line under client and server behaviors, thinking maybe it would simply disable all "fleeentity" ai tasks at gen 2 and above, but that did not work either.

Has anyone else played around with this new customizable option and figured out how to make it work right? I'm stuck.

Link to post
Share on other sites
12 hours ago, jakecool19 said:

That is the wrong key, you need to use "tamingGenerations".

Used that as well with same result. Not working yet, or I'm using it in the wrong place.  Spoke with a few other modders about the issue in Discord and no one is quite sure yet how to get it working. Waiting for further documentation to be made available.

Link to post
Share on other sites
Posted (edited)

max/mingeneration, max/mingenerations, max/mintamingGeneration, max/mintamingGenerations...

Even tried plain "tamingGeneration" and "tamingGenerations" followed by specific generation number I was trying to test it on..

I've used every variation I can think of with same results, and in multiple different places where I could conceive it might be expected in the entity .json file.

Either I'm thinking about it entirely wrong, or it is not working yet. Consensus in the Discord mod help channel was uncertainty on how to implement it, and wait for further info.

Of course if someone has figured out how it should look, please share. ;)
 

 

Edited by Thalius
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.