Jump to content

Game crashes when turning on shadows


Recommended Posts

Just updated to 1.15.3, and the client keeps crashing.

I tried remapping an existing world and the game crashed before remapping completed. I thought it was a mod issue and tried over with a new world but with mods still enabled. The game loaded fine, but I wanted to see how performance was with the new release. Turning on shadows always taxes my system, so I usually start with that after a game update.  Turning on shadows crashed the client.

I tried again with several new worlds but with all mods disabled and had the same results. Client crashes while shadows are trying to load.
Log files attached.


Link to comment
Share on other sites

The crash report references a critical shader error, and the stack trace is full of graphics calls. The crash report also mentions an "Out of resource error".

The log indicates that the game is running on an Intel UHD Graphics 620 video card. Which is to say, no video card at all, but rather a CPU-integrated graphics chip.

Integrated graphics chipsets often do not have their own dedicated video memory, but rather borrow from system memory. In activating shadows, you may have bumped the game's VRAM need to the point where the GPU tried to request more memory that it was allowed to have (because there's a limit on how much it is allowed to take), or more than it was able to request (because the system memory as a whole was already full).

If you do have a dedicated GPU in the system, Vintage Story isn't using it. This happens when the video driver encounters a game it doesn't know, and mistakenly assumes it is not a game, and therefore doesn't need switching to the dedicated GPU. You can force the GPU switch via the graphics driver fairly easily - look up a tutorial based on your GPU manufacturer.

If you do not have a dedicated GPU, and the Intel one is all you have - well, chances are, you'll not be playing with shadows anymore. Rendering changes in 1.15.x may have provoked this. That integrated chip is at the absolute minimum lower border of supported hardware for VS, and thus it's entirely expected to require the majority of details and settings turned down or off in order to run.

Mind you, I cannot guarantee that this is not a bug. You can keep your fingers crossed.

Link to comment
Share on other sites

If that is the case, that will be unfortunate. I've had no significant problems before running low quality shadows.

I looked at vram on my machine. It was pretty low. I have a lot of unused memory on my drive and allocated part of my C drive to boost vram, and it has worked to a degree. I have bloom on, godrays, light source settings, view distance- all turned up pretty high to test it out (I normally keep these things low or off so I can run shadows).  With all those settings turned up, my game is humming along with excellent fps. The moment I turn on shadows though, even with all those other settings turned down, the game crashes.

Hope this can be tweaked a bit. The game looks fantastic with shadows on, even if they are low quality.

Edited by Thalius
Link to comment
Share on other sites

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.