Jump to content

Worsening Stutter

Lumber Jackson

Recommended Posts


I'm experiencing an issue with stutter that seems to get worse the longer I play. There's a split second pause every second or so, and as noted it gets worse the longer I play. I have removed all mods, and it's still there. Even when I leave a world, it's happening on the main menu screen. At first I thought it might be a mod, but it's doing it at the main menu with only the main three mods active. I'm not sure how to even go about figuring out what is causing this. Video settings don't seem to have any effect. 


Here's a video of it stuttering at the main menu, and showing the mod list having everything deactivated except the three mods the game comes with. This is the same thing I experience while playing, it was just easier to capture it at the main menu.


Link to comment
Share on other sites

1 hour ago, Streetwind said:

Could you tell us your system specs?

Also, under video settings, what have you set for VSync and for RAM optimization?

I've tried VSync in off and on mode, and I've tried Optimize Ram in None and Optimize Somewhat. I don't believe I tried it in the aggressive setting. While changing video settings can mitigate the issue somewhat, it still persists. Under cntr-F3, the graph in the bottom shows a huge spike every second or so.

Basic specs are:

Intel i5-4570 CPU @ 3.20Ghz, 4 core

16GB of ram

NVIDIA GeForce GTX 750 Ti

It's an older machine, for sure, but not one I've had issues with running most games at decent graphic settings. I would love to upgrade, but when I started looking into graphics card prices last year I had to put that plan on the back burner. If you need more info let me know what you need. Thanks!

Link to comment
Share on other sites

That's slightly worse than my system (i5-4670K @ 4x3.60 GHz, 16GB, GTX 1060) but still well above the minimum requirements. I can play with 512 blocks view distance at high graphics settings and get a stable 30 fps synced, which is perfectly playable on my adaptive sync monitor.

The stuttering is likely not caused by Vintage Story itself, but something else on your system. I don't know what though.

I've heard it told that setting Threaded Optimization to off in the Nvidia Control Panel has helped people. For me it's on and I don't have stutter. But it's something you can try.

Link to comment
Share on other sites

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.