Jump to content

Immersive First Person Animations


Herbetussy
 Share

Recommended Posts

I know I have probably talked a bit about this in the forums. And Tyron has done a lot in recent updates that has made things like combat a LOT smoother now.

However, small thing, the first person Falx and Spear animations are a little out of sync with the player model's. Which is fine if you click to attack individually for each strike. But if you hold left click, the desync is quite noticeable and jarring. I dont know how this could be fixed especially with the other weapon mods out there but its just a little issue I have noticed.

Like damn I refuse to use the "normal" first person mode. I wanna see my body!

I M M E R S I O N 

I LIKE having to chisel slower because I have to move my hands out of the way to see my ART.

I ACTUALLY LIKE seeing my building materials as view obstructing blocks in both my hands as I struggle to place blocks under me.

I LIKE watching my hand actully KNAP that 24th flint arrow head, even if sometimes I have to hold ALT to see what I am doing.

I LOVE the JANK of shooting my bow at any angle that isn't straight ahead.

The amount of detailed player model animations makes this mode so engaging, and I aint changing back to shitty minecraft floating tool gamey mode.

Though in saying that, the desync in holding down left click while attacking is a bit annoying. Oh and maybe having no shield animation. But ye. Love ya work.

  • Like 1
Link to comment
Share on other sites

I'm curious, if Tyron itself uses the Immersive First Person mode :)

It is much better, than it was, but sometimes you can't see, what you need to see.
Maybe playing with transparency could help. People have 2 eyes and the brain can recalculate image, so you even don't realize you own body. Maybe something like this could be simulated with transparency.

Link to comment
Share on other sites

3 hours ago, AngryRob said:

How do you turn on the good first person mode? I have been away at other games for a bit and came back and now i do not know how to turn on immersive first person mode. 

 

Settings / Interface - Immersive First person Mode
 

image.png.20b7eebcd1b128e9447a403a77d260a1.png

Edited by daretmavi
  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.