Jump to content

Severe framerate stutter after hardware upgrade

Go to solution Solved by LadyWYT,

Recommended Posts

So I did some major hardware upgrades recently and while the game was running fine before, now it's not really possible to play due to the framerate dropping from the mid 70s to single digits every couple of seconds. It ran fine before on the older hardware(even with mods!), and I've ran through just about every troubleshoot I could think of/find, to no avail. I've even wiped the entire game and started over with a clean download.

The previous hardware:

CPU: AMD Phenom II

GPU: Radeon 570

RAM: 8 Gb

The new hardware:

CPU: Ryzen 5 1600, six cores, 3.20 GHz

GPU: Radeon 580

RAM: 16 Gb

My PC has plenty of cooling, and I doubt it's a part issue as I haven't run into issues with other programs. They were previously in my friend's PC before he upgraded, and he was able to play Vintage Story with this hardware without issue(even multiplayer, hosting the world from the same machine). The drivers have all been updated. I've tinkered with the graphical settings and the problem remains the same even at the lowest possible graphics on an unmodded default world. I have also tried closing Discord/other programs while Vintage Story is running and that made no difference either. Likewise, I tried turning off the RAM optimization and it had no effect.

Hence why I'm stumped and I'm hoping someone else has a possible fix. The new hardware should be able to handle the game--I was playing at High settings with a few mods before on my old hardware, and it handled the game fine at around 30 fps or so. The only other thing I can think of is that the FPS seems fine until I move the mouse to try to look around, which is when the framerate definitely tanks. When the game is paused in the settings menu I can see the framerate staying around 70 and dropping to single digits every few seconds, which it really shouldn't if the game is paused.

Edit: I also run Windows 10

Edit 2: I tried reverting back to 1.18.15(which is the last time my friend played) and the issue was still there. Also tried reinstalling Vintage Story onto my SSD instead of the HDD and rerouting the file path to make sure it saved on the SSD as well, and yet the issue still persists so I think I can rule out the HDD being the issue.

Edit 3: After some more tinkering I've figured out that whatever the issue is, it seems tied to the mouse cursor's movement. When I was sitting in the settings menu, the FPS was stable around 70 fps but immediately dropped to single digits when I moved the cursor. The mouse in question is a Corsair Harpoon. I downloaded its software and made sure its drivers were updated--did not solve the issue. After some more googling though, I tried lowering the polling from 1000 htz to 125 hz after others reported similar issues and that fixing it. I'm not sure that doing this fixed the issue, exactly, as something still feels off while playing, but it does seem to have at least stabilized the frame rate to a playable level in Vintage Story. Why it's suddenly an issue though, I don't know--I used the same mouse on the old hardware and had no problems at all.

Edited by LadyWYT
Link to comment
Share on other sites

4 hours ago, Yozo said:

Same motherboard?

It is not. The new is a Gigabyte AB350N with wifi built in.


The old board is an ASUS M5A97 R2.0. It was pretty much an all-or-nothing upgrade this time around.

Link to comment
Share on other sites

Posted (edited)
3 hours ago, Thorfinn said:

My IT guy said sight unseen it's a good bet it's an improperly configured USB controller. That's where he'd start, anyway.

The USB stuff looked fine. The issue seems to have been the BIOS chipset lacking an update.



I'm not going to say that it's 100% fixed as I haven't tested it thoroughly, but the framerate now holds stable at around 50-60 fps without dropping to single digits when I move the mouse.

Edit: After fooling around in the game a bit the framerate continues to read stable around 50-70 fps, but walking/running/looking around is still not really smooth. There's a small jitter/shudder still when I move the crosshair, though it's nowhere near as bad as before. I've tinkered with the settings but so far nothing seems to have smoothed it out.

Edited by LadyWYT
Link to comment
Share on other sites

  • Solution

Okay, I think I've completely solved the issue now.

The majority of the issue was caused by a missing chipset update for the BIOS, which caused the mouse movement to drop the fps(I presume because it was putting unneeded loads on the CPU). Updating the chipset solved this part of the issue, but there was still some subtle jitter leftover.

After much poking around with the settings, the rest of the solution was dropping the Max FPS from 75 down to around 30. The frames run jitter-free now!

  • Like 1
Link to comment
Share on other sites

28 minutes ago, Thorfinn said:

I figured updating all drivers was just part of setting up a new computer, but you did remember to check all your other hardware for updates, right?

I did, yeah. It's been running smoothly since the chipset update 😀 The reason that the chipset driver got missed is that I thought the most recent version wasn't installing, so I went with a slightly older version first. Turns out it was actually installing; it was just slow due to being on an HDD and not an SSD.

Link to comment
Share on other sites

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.