Jump to content

Am I missunderstanding Exploration Mode?


DancingHoskuld
 Share

Recommended Posts

Creature Hostility has three settings: "aggressive" (wolves and monsters attack on sight, other animals when provoked), "passive" (creatures only attack when provoked), and "never hostile" (creatures do not fight back at all).

Exploration Mode uses "passive" by default. That means that, while you will not be pounced by everything in sight, combat can still happen. What exactly consititutes "provoked" may vary from creature to creature. For example, male bighorn sheep insist on proper social distancing, and will hit you if you stand right next to them.

Try making a new world, select Exploration Mode, and then the Customize button at the bottom of the screen. There, change Creature Hostility to "never hostile". Then try and see if that is what you were looking for in gameplay.

  • Like 1
Link to comment
Share on other sites

Also, it is a thing that if animals take damage from falling, they blame you and will attack you (that is, the code is such that taking any damage is interpreted as a hostile player act, regardless of whether or not the player actually caused it).  At least last I knew.  So that might have also been a factor.  Though if you change to never hostile mode I think it shouldn't matter.

Also, you can change individual settings after a world is made, you don't have to start a new world.   This wiki page lists the available commands:  https://wiki.vintagestory.at/index.php?title=List_of_server_commands/worldconfig

Specifically, you want /worldconfig creatureHostility [aggressive|passive|off]

Note that you may have to quit and reload to get the setting to actually take effect.

 

 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

  • 3 months later...
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.