Jump to content

Easy way to toggle greenhouse effect on and off

Professor Dragon

Recommended Posts


I'd like to be able to "open a vent" in my "greenhouse" and be able to switch it from the greenhouse effect, to not.

For example, to have a vertical trapdoor in a wall, if opened, turn the effect off. And closed, on.
(I don't mind about the four hour checking delay. That's fine.)


Similar to how in a real greenhouse there are vents that you open in hot weather, and close at night.


I see that a lot of people have trouble in activating a greenhouse. My issue is the opposite! I can't "break" my greenhouse.

I have tried:

  • Changing a full block roof glass block to a closed trapdoor.
    (I don't want it open, to avoid drifters falling through.)
  • Replacing some of the full block glass wall windows with half block glass windows.

However even after many in-game hours/days, these have not removed the "greenhouse" flag from the farmland.

Which is a bit of an issue in a warm climate. Although the primary purpose of a greenhouse is useful to extend the season, I have also very much appreciated been able to work on crops without worrying about drifters.

And no, I don't want to manually remove walls or ceilings, although I could if that would be reliable. Hmmm. I haven't tried some fences instead of glass yet . . .


If anyone has any existing solutions to this conundrum, let me know.

Thank you!


Edited by TheDancingFox
  • Like 1
Link to comment
Share on other sites

On 5/10/2022 at 7:44 AM, Maelstrom said:

knocking out just one block should do the trick.

Yes, it did.  I took a wall block right out and that worked.


It would be nice though to have a block in its place. It's a bit unnerving having drifters all around, even if they haven't figured out yet a way to get me through a 1x1 hole.


I haven't tried the fence . . . should get onto that.

Link to comment
Share on other sites

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.