Jump to content

Stabler De-Jank and Game Juice Update (1.17.3)


Tyron
 Share

Recommended Posts

Dear Extraordinary Survivalists
v1.17.3, a stable release, can now be downloaded through the account manager.

Time for another bugfix release. Version 1.17 seems to be looking pretty good by now. Possibly the last or 2nd last release for 1.17.x \o/

fall.thumb.jpg.ff782e7180f85aadb61c114ab486b580.jpg
Screenshot by kippy#4986 on discord
 

Game updates

  • Feature: Can now configure crop and berry bush grow rates via /worldconfigcreate float cropGrowthRateMul [0.1 ... 10]
  • Tweak: Improve performance during temporal storms (technical info: don't compute new rust overlay for distant geometry)
  • Tweak: Fine tune frost overlay on creatures
  • Fixed: Able to use /waypoint on worlds with maps disabled
  • Fixed: Filling quern with items reset the grind timer
  • Fixed: Game crashing when placing vintage beef on shelves
  • Fixed: Berry bush berry harvest yield not correctly increased
  • Fixed: Berry yield from breaking berry bushes was not affected by the character forage stat
  • Fixed: Fruit press sometimes not yielding 10L of juice
  • Fixed: Not able to place 4 crocks in one block in some cases
  • Fixed: Quern not stopping when opening handbook while grinding
  • Fixed: Setting daysPerMonth config via serverconfig.json did not apply correctly
  • Fixed: Weird clipping issue with rush matting
  • Fixed: Fences and other blocks sometimes getting replaced by grass
  • Fixed: Lung capacity world config not applying correctly
  • Fixed: Endlessly falling snow layer blocks
  • Fixed: Shields in the decorative blocks tab
  • Fixed: Might finally fix a crash related to fruit trees
  • Api tweak: Vanilla item/block codes in a exported schematic should now all be prefixed with game
  • Api Fixed: Plant container fillHeight not respecting block type

 


View full record

  • Like 4
  • Thanks 7
Link to comment
Share on other sites

At first, I thought iCue (Corsair mouse software) was causing severe issues with this build. Performance tanked hard. Turned out it was a Windows 11 update that borked everything. A reinstall has shown that I am getting about 15FPS more than I did before! I don't know if my drivers are just working better or if something was done to the 1.17.x builds, but it runs like liquid butter and I'm pleased!

Thanks always for all of the awesome work, the game is amazing! Can't wait to see what's ahead! :)

  • Like 1
Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.