Jump to content

v1.18.0-rc.6 Lore Update: The Resonance Archives


Recommended Posts

Dear Extraordinary Survivalists
v1.18.0-rc.6, a release candidate, can now be downloaded through the account manager (section "Other Goodies").

More bugs fixed. Stable release very Soon™
This release includes some optimizations to reduce lag spikes in some areas of the game, which we'd like to test before stable. Also 1.18 had a major impacting on Vintagehosting, due to another performance issue which should be addressed with this one.

Screenshot by Mercatto#6367

Game updates

  • Tweak: (Experimental) Trader caravans can now generate in slightly more places (more tolerant towards non-flat terrain) - this is reverted in v1.18.0-rc.7, it tended to put wheels into hillsides
  • Tweak: Mitigated a few sources of lag spikes on client and server (Technical info: Reduced lock contention, removed some unnecessary bits of code)
  • Api Tweak: Added guid field to Waypoints
  • Api Fixed: Renamed container property "transitionSpeedMulByType" to simply "transitionSpeedMul" which should make it work as intended
  • 1.18 related changes
    • Tweak/Fixes: Various fine tuning on the main story event
    • Fixed: Server-side exception when a user tries to break blocks without breaking permissions
    • Fixed: Major server-side performance issue on high end hardware that runs many active servers (Technical info: Game server was spinning up waaaay too many threads on high core cpus)
    • Fixed: Trader caravans, occasional chest and storage vessel placement outside the caravan (1.18-rc1+ issue)
    • Fixed: Should fix metal blocks from 1.17 not remapped correctly to 1.18 metal blocks
    • Api Fixed: Unable to properly format translatable TextCommandResult messages


View full record

  • Like 7
  • Amazing! 2
  • Thanks 1
Link to comment
Share on other sites

When I run the 1.18.0-rc.6 installer I get this prompt. This did not happen to me with previous versions.
check your internet connection. It is not possible to access the Microsoft Defender Smart Screen or help you decide if this application can run without problems.



Edited by artemax44
Link to comment
Share on other sites

8 hours ago, Streetwind said:

The integrated update worked fine for me. Went from rc2 to rc6 without issues.

On a dual install? Hmm. I can run the installer normal just fine, but it updates my "default" install instead of the 1.18 install. Guess I'll try running as admin, might force it. 

Edited by Rhyagelle
Link to comment
Share on other sites

Yep, I have four parallel installs at the moment: 1.14.7, 1.16.1, 1.17.11, and 1.18.0-rc.6. Although admittedly I haven't touched the two older ones in a long while... :D

I start each one with a custom shortcut that remaps the data folder, so they don't interfere with each other. The default VS data folder under %appdata% is completely unused.

When I updated rc.2 to rc.6 from within the game, only the 1.18 instance was touched. The other installs remain as they were.

Link to comment
Share on other sites

I have no idea why it refuses to work for me, then. I have my shortcut saved correctly, I presume, given that it worked after all your help before (thanks again by the way!). I've also tried running as admin, but that didn't seem to work either. Just gets stuck on preparing the install. I'll try a few other things, hopefully it works.


Even manual updating gets stuck on preparing to install, and not just for my secondary install. I don't think the issue is on my end, after all.  


Okay, so only the install version worked for me, so yeah, definitely think it was a problem with the update versions of rc.6. If it helps to know, I'm on the very latest version of Windows 11.

Edited by Rhyagelle
Link to comment
Share on other sites

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.