Jump to content

Reinstall?


Kicks

Recommended Posts

I also have separate installations. Also looking forward to a new world to take advantage of ALL the THINGS right from the start! Waiting for more stabilization first.

  • Amazing! 1
Link to comment
Share on other sites

How do you use alternate directories, @Streetwind? I installed the executable in a different location, but it still wants to use the same data directory. My workaround so far has been renaming VintagestoryData as needed, but that seems a little more cumbersome than it needs be.

  • Like 1
Link to comment
Share on other sites

9 hours ago, Thorfinn said:

How do you use alternate directories, @Streetwind? I installed the executable in a different location, but it still wants to use the same data directory. My workaround so far has been renaming VintagestoryData as needed, but that seems a little more cumbersome than it needs be.

I've written about it here. If it doesn't work for you, tell me at which step it's failing.

  • Like 2
Link to comment
Share on other sites

7 hours ago, Streetwind said:

I've written about it here. If it doesn't work for you, tell me at which step it's failing.

This is certainly not my thread, but I recently tried to do this and failed miserably. Any help would be appreciated. 😅

I wanted 1.17.x for stable use on servers (so I could launch and play modded servers) and another install of the newest update (no mods, just testing), but commands broke the 1.17.x install. It wouldn't read the mods folder or anything, and for the new one I set the data path to, it wouldn't automatically create the rest of the folder structure. This would show up in game, too, almost like it was corrupted. I tried various ways, but the last command I used was:

"D:\PC Games\Vintagestory\Vintagestory.exe" --dataPath D:\PC Games\Vintagestory\Data --addModPath D:\PC Games\Vintagestory\Data\Mods"

I ended up adding a ModPath because if I didn't, it would read the 1.17.x mod folder (and not let me disable them). 

Here's a screenshot of what happens in game. It not only breaks my stable 1.17.x install, but this happens in the 1.18 install: image.png

Any ideas on what I did wrong? 

Edited by Rhyagelle
  • Like 1
Link to comment
Share on other sites

I don't know how you set things up, but vs defaults to VintagestoryData, not Vintagestory\Data. Personally,  I think I'll shorten it to vs118

[Edit]

Are you trying to keep the data inside your install directory? 

[/Edit]

 

Edited by Thorfinn
  • Like 1
Link to comment
Share on other sites

55 minutes ago, Rhyagelle said:

I tried various ways, but the last command I used was:

"D:\PC Games\Vintagestory\Vintagestory.exe" --dataPath D:\PC Games\Vintagestory\Data --addModPath D:\PC Games\Vintagestory\Data\Mods"

Notice how there's an excess quotation mark after vintagestory.exe? That's breaking your path. Removing it (but keeping the quotation marks at the beginning and the end) should hopefully fix things.

  • Like 1
Link to comment
Share on other sites

1 hour ago, Thorfinn said:

I don't know how you set things up, but vs defaults to VintagestoryData, not Vintagestory\Data. Personally,  I think I'll shorten it to vs118

[Edit]

Are you trying to keep the data inside your install directory? 

[/Edit]

 

So I should make a folder in my 1.18 install directory called VintagestoryData, rather than an individual folder? Will that fix it?

I want 1.17.x and 1.18 to have different folders entirely, so that I can still play my 1.17.x servers, without having to disable mods every time I launch 1.18 and have to reenable them when I go back to 1.17.x. If that makes sense. 

13 minutes ago, Streetwind said:

Notice how there's an excess quotation mark after vintagestory.exe? That's breaking your path. Removing it (but keeping the quotation marks at the beginning and the end) should hopefully fix things.

OMG I can't believe I missed that! I'll try it as soon as I get home, thank you! xD

Link to comment
Share on other sites

Hey, forgot to get back to you. Thanks for the heads up, @Streetwind. Thanks, too, @Rhyagelle. I had to use the modpath switch, too. Probably end up having to use the logs switch, too, but we will see. I also found that at least in Win10 Pro, apparently you cannot use the double quotes unless you actually need them. Leave them out if your path has no spaces, or possibly special characters. Don't know.

  • Like 1
  • Cookie time 1
Link to comment
Share on other sites

When I installed the .Net7 release, I decided to try out your suggested path, @Rhyagelle, because I am the only one who is going to be using that machine. Works really well. With one proviso -- I think you have to tell the installer NOT to launch. Just exit, edit the shortcut as @Streetwindexplains above ( --dataPath  ) and things come up fine, i.e., you place the mods in the D:\Games\VS117\Data\Mods directory that it helpfully creates for you when you first run it. If you launch from the installer, it seems to have problems figuring out your edited paths.

The downside is it might be a bit confusing -- there is both a .\Mods directory with the game files and a .\Data\Mods directory where you place user mods. I don't think it's critical which they reside in, but probably should not be both, and if user mods are always in the .\Data\Mods it is easier to tell at a glance if you have an old version that needs to be deleted.

  • Like 1
Link to comment
Share on other sites

So, I tried to make the new command and remove the old double " that was there, but with one at the start and one at the end, I get the following "error".

 

DNmmFXU.png

It accepts it with the extra " there though. I'm really not sure what I'm doing wrong. lmao Using Windows 11, by the way. 

Edited by Rhyagelle
Link to comment
Share on other sites

Another approach (until you can get your command line working) is to rename the folder of the version you will not be playing. This prevents those mods from loading.

When you want to play the other version, simply rename the folder(s) again (correcting the one that you want to play, and making an incorrect name for the one you will not be playing).

  • Like 1
Link to comment
Share on other sites

Was able to duplicate your problem in Windows 10, @Rhyagelle

Problem is you have a space in your executable path, so that needs to be enclosed in quotes, and you have a space in your data path, so that also has to be enclosed. So here's what works on mine, albeit the space is in a different part of the path.

"C:\Users\Lothar\AppData\Roaming\Vintagestory 117\Vintagestory.exe" --dataPath "C:\Users\Lothar\AppData\Roaming\Vintagestory 117\Data"

[EDIT]

Just like that. Four double quotes, and you don't need --addModPath -- that's just for if you have mods not only in your data directory, but also somewhere else. For example, if this was on my machine I'm testing the .Net7 version on, I'd leave the mods where they are in whatever I called 1.17, and include that with the --addModPath switch. Quite smart, on reflection. It looks like you need to only update mods for any version in one place, but by changing the --dataPath switch, you can support different instances of the game with different settings.

One of the reasons I don't use spaces for anything in the directory structure, since space is a delimiter, and you have to figure out how each thing you use escapes that.

[/EDIT]

Edited by Thorfinn
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

That causes the first set of issues I was having from before, though. Which prevents me from toggling, adding or remove mods or changing settings because, I guess, it's now trying to read for the second install. I also get the broken/greyed out information in settings etc again as seen above.

2 hours ago, dakko said:

Another approach (until you can get your command line working) is to rename the folder of the version you will not be playing. This prevents those mods from loading.

When you want to play the other version, simply rename the folder(s) again (correcting the one that you want to play, and making an incorrect name for the one you will not be playing).

If that works, I'll have to do that, because it's just not working at all for me. I wish the devs would just make this a possibility without the headaches... :(

Link to comment
Share on other sites

???

The first one you posted was

Quote

"D:\PC Games\Vintagestory\Vintagestory.exe" --dataPath D:\PC Games\Vintagestory\Data --addModPath D:\PC Games\Vintagestory\Data\Mods"

That's missing a double quote right after the space after --dataPath and right before the pathname. Indeed, it's actually missing 3 double quotes.

What you want is

Quote

"D:\PC Games\Vintagestory\Vintagestory.exe" --dataPath "D:\PC Games\Vintagestory\Data"

Or at least that's what works in Windows 10.

[EDIT]

If you really had another path you want to pull mods from, you would use

Quote

"D:\PC Games\Vintagestory\Vintagestory.exe" --dataPath "D:\PC Games\Vintagestory\Data" --addModPath "D:\PC Games\MyOtherModPath"

Note there are quotes around each pathname.

I do agree that it would have been easier for an end user if there had been a gameConfig.json in the executable directory. But then you could not have multiple sets of modConfigs and clientSettings.json and serverConfig.json for the various gamestyles you might like to play without maintaining separate installs. This way, all you have to do is copy/paste the shortcut, change the target, and you can create a new modlist/config without changing the settings on all your other games in progress. The more I think on the options that gives, the more impressed I am with the choice @Tyron made.

[/EDIT]

Edited by Thorfinn
  • Like 1
Link to comment
Share on other sites

6 hours ago, Thorfinn said:

Just like that. Four double quotes

Thanks for sussing that out :)I'll edit my post to reflect how to properly place the quotation marks.

EDIT: Actually, nevermind, I think I'll make a new post entirely, since that one isn't as nice as I want it to be.

Edited by Streetwind
  • Like 2
Link to comment
Share on other sites

7 hours ago, Rhyagelle said:
10 hours ago, dakko said:

Another approach (until you can get your command line working) is to rename the folder of the version you will not be playing. This prevents those mods from loading.

When you want to play the other version, simply rename the folder(s) again (correcting the one that you want to play, and making an incorrect name for the one you will not be playing).

If that works, I'll have to do that, because it's just not working at all for me. I wish the devs would just make this a possibility without the headaches... :(

It does work. It is what I started doing when first experiencing the mod issue with 1.17. Or maybe it was 1.16, I can't remember.

  • Like 2
Link to comment
Share on other sites

7 hours ago, Thorfinn said:

???

The first one you posted was

That's missing a double quote right after the space after --dataPath and right before the pathname. Indeed, it's actually missing 3 double quotes.

What you want is

Or at least that's what works in Windows 10.

[EDIT]

If you really had another path you want to pull mods from, you would use

Note there are quotes around each pathname.

I do agree that it would have been easier for an end user if there had been a gameConfig.json in the executable directory. But then you could not have multiple sets of modConfigs and clientSettings.json and serverConfig.json for the various gamestyles you might like to play without maintaining separate installs. This way, all you have to do is copy/paste the shortcut, change the target, and you can create a new modlist/config without changing the settings on all your other games in progress. The more I think on the options that gives, the more impressed I am with the choice @Tyron made.

[/EDIT]

I'm sorry, I just realized how confusingly I worded myself there. I didn't mean it was the same command that was giving me problems, only that it was giving me the same problems as the command I tried before. I'll try copying and pasting yours directly, hopefully it's just acting funky. Thanks so much for being patient with my problems! xD

EDIT

OMG! It seems to be working! I can even toggle options now and there's no greyed out options in the mods directory! Thank you guys so much! :)

Edited by Rhyagelle
  • Cookie time 2
Link to comment
Share on other sites

7 hours ago, dakko said:

It does work. It is what I started doing when first experiencing the mod issue with 1.17. Or maybe it was 1.16, I can't remember.

Indeed. That is how we had been managing multiple instances with various game and mod settings, just renaming directories. It's not until last night that I realized that @Tyronalready gave us the ability to do that without mucking around. Copy/paste the shortcut, rename it so you can remember what it does, edit the target field, and you have only to restart the game to have created the new instance. Select whatever mods and settings you like there. They don't affect your other instances.

[EDIT]

For example, if @Rhyagelledecided she wanted to try a new game with bunch of different settings in Primitive Survival, and didn't want to have to remember what to change them back to for her old game, all she would have to do is copy/paste the shortcut on the desktop, and change her target field to:

Quote

"D:\PC Games\Vintagestory\Vintagestory.exe" --dataPath "D:\PC Games\Vintagestory\PrimitiveTest1" --addModPath "D:\PC Games\Vintagestory\Data"

restart the game, and it will create the PrimitiveTest1 directory in the executable directory, parallel with the her Data directory. By telling this instance to pull mods from her other standard instance, she doesn't even have to copy all those mods over. She doesn't have to remember to keep them in sync. @Tyronjust loads them into the Mod Manager for her to choose from. All that remains is to edit the values of Primitive Survival in modConfig, create a new world, and play.

Since he's put that much forethought into it, I'd also guess that the mods in this new instance's mods directory load order is later, to serve as a means of overriding the default.

[/EDIT]

 

11 hours ago, Streetwind said:

I think I'll make a new post entirely, since that one isn't as nice as I want it to be.

Cool. I look forward to it. Are you going to show the advanced usage, too, or do you figure that's sufficiently unusual desire that anyone who knows he wants that can intuit it out? 

[EDIT]

Just noticed that autocorrect replaced the double dash before "addModPath" with a single dash. I've corrected autocorrect. 

[/EDIT] 

Edited by Thorfinn
  • Like 1
Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.